# CVE-2022-36436: VNCAuthProxy authentication bypass vulnerability

> Remote attackers can bypass authentication to access or disconnect VNC sessions via the VNCAuthProxy server without credentials.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Sep 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-237r-mx84-7x8c, PYSEC-2022-267

## What is CVE-2022-36436?

CVE-2022-36436 is a critical authentication bypass vulnerability in n/a, published on 14 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OSU Open Source Lab VNCAuthProxy through 1.1.1 is affected by an vncap/vnc/protocol.py VNCServerAuthenticator authentication-bypass vulnerability that could allow a malicious actor to gain unauthorized access to a VNC session or to disconnect a legitimate user from a VNC session. A remote attacker with network access to the proxy server could leverage this vulnerability to connect to VNC servers protected by the proxy server without providing any authentication credentials. Exploitation of this issue requires that the proxy server is currently accepting connections for the target VNC server.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-36436?

3 open source packages ship an affected version, including vncauthproxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vncauthproxy` | PyPI | All versions | 1.2.0 |
| `vncauthproxy` | PyPI | All versions | 1.2.0 |
| `vncauthproxy` | PyPI | All versions | 1.2.0 |

Products: Osuosl Twisted Vnc Authentication Proxy.

## How do I fix CVE-2022-36436?

Upgrade vncauthproxy to 1.2.0 or later.

## Is CVE-2022-36436 being exploited?

There is no known exploitation of CVE-2022-36436 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36436 and fix it if it is affected.

What it is: CVE-2022-36436 is a critical authentication bypass vulnerability in n/a, published on 14 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36436 in the wild and no public exploit code.

Affected packages and fixed versions:
- vncauthproxy (PyPI): affected all versions; fixed in 1.2.0
- vncauthproxy (PyPI): affected all versions; fixed in 1.2.0
- vncauthproxy (PyPI): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36436/ (Markdown: https://insights.sbomify.com/CVE-2022-36436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36436
- OSV: https://osv.dev/vulnerability/CVE-2022-36436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36436/
Summaries are generated and may contain mistakes; the official description above is the record.
