# CVE-2022-36437: Hazelcast connection caching

> Remote unauthenticated attackers can access and manipulate cluster data by impersonating authenticated connections in Hazelcast.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Dec 2022
- **Updated:** 11 Apr 2025
- **Also known as:** GHSA-c5hg-mr8r-f6jp

## What is CVE-2022-36437?

CVE-2022-36437 is a critical authentication bypass vulnerability in n/a, published on 29 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Connection handler in Hazelcast and Hazelcast Jet allows a remote unauthenticated attacker to access and manipulate data in the cluster with the identity of another already authenticated connection. The affected Hazelcast versions are through 4.0.6, 4.1.9, 4.2.5, 5.0.3, and 5.1.2. The affected Hazelcast Jet versions are through 4.5.3.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2022-36437?

28 open source packages ship an affected version, including com.hazelcast:hazelcast, com.hazelcast.jet:hazelcast-jet and com.hazelcast.jet:hazelcast-jet-enterprise. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.hazelcast:hazelcast` | Maven | All versions | 3.12.13 |
| `com.hazelcast:hazelcast` | Maven | All versions | 3.12.13 |
| `com.hazelcast:hazelcast` | Maven | From 4.0 to 4.0.6 | None |
| `com.hazelcast:hazelcast` | Maven | From 4.0 to 4.0.6 | None |
| `com.hazelcast:hazelcast` | Maven | From 4.1 | 4.1.10 |
| `com.hazelcast:hazelcast` | Maven | From 4.1 | 4.1.10 |
| `com.hazelcast:hazelcast` | Maven | From 4.2 | 4.2.6 |
| `com.hazelcast:hazelcast` | Maven | From 4.2 | 4.2.6 |
| `com.hazelcast:hazelcast` | Maven | From 5.0 | 5.0.4 |
| `com.hazelcast:hazelcast` | Maven | From 5.0 | 5.0.4 |
| `com.hazelcast:hazelcast` | Maven | From 5.1 | 5.1.3 |
| `com.hazelcast:hazelcast` | Maven | From 5.1 | 5.1.3 |
| `com.hazelcast.jet:hazelcast-jet` | Maven | All versions | 4.5.4 |
| `com.hazelcast.jet:hazelcast-jet` | Maven | All versions | 4.5.4 |
| `com.hazelcast.jet:hazelcast-jet-enterprise` | Maven | All versions | 4.5.4 |
| `com.hazelcast.jet:hazelcast-jet-enterprise` | Maven | All versions | 4.5.4 |
| `com.hazelcast:hazelcast-enterprise` | Maven | All versions | 3.12.13 |
| `com.hazelcast:hazelcast-enterprise` | Maven | All versions | 3.12.13 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 4.0 to 4.0.6 | None |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 4.0 to 4.0.6 | None |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 4.1 | 4.1.10 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 4.1 | 4.1.10 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 4.2 | 4.2.6 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 4.2 | 4.2.6 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 5.0 | 5.0.4 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 5.0 | 5.0.4 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 5.1 | 5.1.3 |
| `com.hazelcast:hazelcast-enterprise` | Maven | From 5.1 | 5.1.3 |

Products: Hazelcast Hazelcast, Hazelcast Hazelcast-Jet.

## How do I fix CVE-2022-36437?

Upgrade com.hazelcast:hazelcast to a fixed version for your release line: 3.12.13, 4.1.10, 4.2.6 or 5.0.4.

## Is CVE-2022-36437 being exploited?

There is no known exploitation of CVE-2022-36437 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-26168](https://insights.sbomify.com/CVE-2020-26168/): Auth bypass in n/a (critical 9.8)
- [CVE-2023-33265](https://insights.sbomify.com/CVE-2023-33265/): Hazelcast Executor Services don't check client permissions properly (high 8.8)
- [CVE-2016-10750](https://insights.sbomify.com/CVE-2016-10750/): Deserialization of Untrusted Data in Hazelcast (high 8.1)
- [CVE-2023-45859](https://insights.sbomify.com/CVE-2023-45859/): Missing permission checks on Hazelcast client protocol (high 7.6)
- [CVE-2022-0265](https://insights.sbomify.com/CVE-2022-0265/): Improper Restriction of XML External Entity Reference in hazelcast/hazelcast (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36437 and fix it if it is affected.

What it is: CVE-2022-36437 is a critical authentication bypass vulnerability in n/a, published on 29 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36437 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.hazelcast:hazelcast (Maven): affected all versions; fixed in 3.12.13
- com.hazelcast:hazelcast (Maven): affected all versions; fixed in 3.12.13
- com.hazelcast:hazelcast (Maven): affected from 4.0 up to 4.0.6; no fix listed
- com.hazelcast:hazelcast (Maven): affected from 4.0 up to 4.0.6; no fix listed
- com.hazelcast:hazelcast (Maven): affected from 4.1; fixed in 4.1.10
- com.hazelcast:hazelcast (Maven): affected from 4.1; fixed in 4.1.10
- com.hazelcast:hazelcast (Maven): affected from 4.2; fixed in 4.2.6
- com.hazelcast:hazelcast (Maven): affected from 4.2; fixed in 4.2.6
- com.hazelcast:hazelcast (Maven): affected from 5.0; fixed in 5.0.4
- com.hazelcast:hazelcast (Maven): affected from 5.0; fixed in 5.0.4
- com.hazelcast:hazelcast (Maven): affected from 5.1; fixed in 5.1.3
- com.hazelcast:hazelcast (Maven): affected from 5.1; fixed in 5.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36437/ (Markdown: https://insights.sbomify.com/CVE-2022-36437/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36437
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36437
- OSV: https://osv.dev/vulnerability/CVE-2022-36437

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36437/
Summaries are generated and may contain mistakes; the official description above is the record.
