{"answers":{"affected":"3 open source packages ship an affected version, including pulp-ansible. It affects 4 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3644 exists.","fix":"Upgrade pulp-ansible to 0.15.0 or later.","what":"CVE-2022-3644 is a medium-severity vulnerability in Redhat Satellite, published on 25 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-3644 and fix it if it is affected.\n\nWhat it is: CVE-2022-3644 is a medium-severity vulnerability in Redhat Satellite, published on 25 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3644 exists.\n\nAffected packages and fixed versions:\n- pulp-ansible (PyPI): affected all versions; fixed in 0.15.0\n- pulp-ansible (PyPI): affected all versions; fixed in 0.15.0\n- pulp-ansible (PyPI): affected all versions; fixed in 0.15.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-3644/ (Markdown: https://insights.sbomify.com/CVE-2022-3644/index.md)","id":"CVE-2022-3644","markdown":"https://insights.sbomify.com/CVE-2022-3644/index.md","name":"CVE-2022-3644","record":{"aliases":["GHSA-qv37-mfjf-42h8","PYSEC-2026-900"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ansible content server","requires_auth":"low_privilege","summary":"Attackers can read plaintext authentication tokens for remote collections via the API due to improper storage and exposure in pulp_ansible.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"pulp_ansible","vendor":"pulpproject"},{"product":"ansible_automation_platform","vendor":"redhat"},{"product":"satellite","vendor":"redhat"},{"product":"update_infrastructure","vendor":"redhat"}],"cvss":{"score":5.5,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"},{"id":"CWE-256","name":"Plaintext Storage of a Password"}],"description":"The collection remote for pulp_ansible stores tokens in plaintext instead of using pulp's encrypted field and exposes them in read/write mode via the API () instead of marking it as write only.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Plaintext storage of tokens in pulp_ansible","id":"CVE-2022-3644","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"redhat:satellite","products":["redhat:satellite"],"type":"information_disclosure","year":"2022"},"n_packages":3,"n_references":1,"next":{"headline":"Linux Kernel BPF segment.c nilfs_attach_log_writer memory leak","id":"CVE-2022-3646"},"packages":[{"ecosystem":"PyPI","fixed":["0.15.0"],"introduced":["0"],"last_affected":[],"package":"pulp-ansible","purl":null,"source":"GHSA-qv37-mfjf-42h8"},{"ecosystem":"PyPI","fixed":["0.15.0"],"introduced":["0"],"last_affected":[],"package":"pulp-ansible","purl":"pkg:pypi/pulp-ansible","source":"GHSA-qv37-mfjf-42h8"},{"ecosystem":"PyPI","fixed":["0.15.0"],"introduced":["0"],"last_affected":[],"package":"pulp-ansible","purl":"pkg:pypi/pulp-ansible","source":"PYSEC-2026-900"}],"prev":{"headline":"Denial of service in Linux","id":"CVE-2022-3643"},"products":["pulp_ansible"],"published":"2022-10-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-07","vendors":["n/a"]},"summary":"Attackers can read plaintext authentication tokens for remote collections via the API due to improper storage and exposure in pulp_ansible.","url":"https://insights.sbomify.com/CVE-2022-3644/"}