# CVE-2022-3644: Plaintext storage of tokens in pulp_ansible

> Attackers can read plaintext authentication tokens for remote collections via the API due to improper storage and exposure in pulp_ansible.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Oct 2022
- **Updated:** 7 May 2025
- **Also known as:** GHSA-qv37-mfjf-42h8, PYSEC-2026-900

## What is CVE-2022-3644?

CVE-2022-3644 is a medium-severity vulnerability in Redhat Satellite, published on 25 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

The collection remote for pulp_ansible stores tokens in plaintext instead of using pulp's encrypted field and exposes them in read/write mode via the API () instead of marking it as write only.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-256 (Plaintext Storage of a Password)

## Which versions are affected by CVE-2022-3644?

3 open source packages ship an affected version, including pulp-ansible. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pulp-ansible` | PyPI | All versions | 0.15.0 |
| `pulp-ansible` | PyPI | All versions | 0.15.0 |
| `pulp-ansible` | PyPI | All versions | 0.15.0 |

Products: Pulpproject Pulp Ansible, Redhat Ansible Automation Platform, Redhat Satellite, Redhat Update Infrastructure.

## How do I fix CVE-2022-3644?

Upgrade pulp-ansible to 0.15.0 or later.

## Is CVE-2022-3644 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3644 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3644 and fix it if it is affected.

What it is: CVE-2022-3644 is a medium-severity vulnerability in Redhat Satellite, published on 25 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3644 exists.

Affected packages and fixed versions:
- pulp-ansible (PyPI): affected all versions; fixed in 0.15.0
- pulp-ansible (PyPI): affected all versions; fixed in 0.15.0
- pulp-ansible (PyPI): affected all versions; fixed in 0.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3644/ (Markdown: https://insights.sbomify.com/CVE-2022-3644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3644
- OSV: https://osv.dev/vulnerability/CVE-2022-3644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3644/
Summaries are generated and may contain mistakes; the official description above is the record.
