# CVE-2022-3647: Redis Crash Report debug.c sigsegvHandler denial of service

> A disputed vulnerability in Redis crash reporting allows a difficult-to-exploit denial of service, requiring a patch to resolve.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Oct 2022
- **Updated:** 15 Apr 2025
- **Also known as:** ALPINE-CVE-2022-3647, AZL-11325, BIT-keydb-2022-3647, BIT-redis-2022-3647, BIT-valkey-2022-3647, CLEANSTART-2026-PT45918, DEBIAN-CVE-2022-3647, ECHO-f276-11b7-fc07, GHSA-8vvp-2mv7-px5c, SUSE-SU-2022:4168-1, SUSE-SU-2022:4169-1, openSUSE-SU-2024:12468-1

## What is CVE-2022-3647?

CVE-2022-3647 is a low-severity denial of service vulnerability in Redis, published on 21 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

** DISPUTED ** A vulnerability, which was classified as problematic, was found in Redis up to 6.2.7/7.0.5. Affected is the function sigsegvHandler of the file debug.c of the component Crash Report. The manipulation leads to denial of service. The complexity of an attack is rather high. The exploitability is told to be difficult. The real existence of this vulnerability is still doubted at the moment. Upgrading to version 6.2.8 and 7.0.6 is able to address this issue. The patch is identified as 0bf90d944313919eb8e63d3588bf63a367f020a3. It is recommended to apply a patch to fix this issue. VDB-211962 is the identifier assigned to this vulnerability. NOTE: The vendor claims that this is not a DoS because it applies to the crash logging mechanism which is triggered after a crash has occurred.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2022-3647?

3 open source packages ship an affected version, including redis, keydb and valkey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redis` | Bitnami | All versions | 6.2.8, 7.0.6 |
| `keydb` | Bitnami | All versions | 6.2.8, 7.0.6 |
| `valkey` | Bitnami | All versions | 6.2.8, 7.0.6 |
| `redis` | SUSE:Linux Enterprise Module for Server Applications 15 SP3 | All versions | 6.0.14-150200.6.14.1 |
| `redis` | SUSE:Linux Enterprise Module for Server Applications 15 SP4 | All versions | 6.2.6-150400.3.6.1 |
| `redis` | openSUSE:Leap 15.3 | All versions | 6.0.14-150200.6.14.1 |
| `redis` | openSUSE:Leap 15.4 | All versions | 6.2.6-150400.3.6.1 |
| `redis` | openSUSE:Tumbleweed | All versions | 7.0.5-3.1 |

Products: Redis Redis.

## How do I fix CVE-2022-3647?

Upgrade redis to a fixed version for your release line: 6.2.8 or 7.0.6.

## Is CVE-2022-3647 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3647 exists.

## Other vulnerabilities in Redis

- [CVE-2022-0543](https://insights.sbomify.com/CVE-2022-0543/): Debian-specific Redis Server Lua Sandbox Escape (critical 10.0, exploited in the wild)
- [CVE-2026-23479](https://insights.sbomify.com/CVE-2026-23479/): redis-server use-after-free in unblock client flow may allow remote code execution (high 7.7)
- [CVE-2026-25243](https://insights.sbomify.com/CVE-2026-25243/): redis-server RESTORE invalid memory access may allow remote code execution (high 7.7)
- [CVE-2025-62507](https://insights.sbomify.com/CVE-2025-62507/): Redis: Bug in XACKDEL may lead to stack overflow and potential RCE (high 7.7)
- [CVE-2025-48367](https://insights.sbomify.com/CVE-2025-48367/): Redis DoS Vulnerability due to bad connection error handling (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3647 and fix it if it is affected.

What it is: CVE-2022-3647 is a low-severity denial of service vulnerability in Redis, published on 21 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3647 exists.

Affected packages and fixed versions:
- redis (Bitnami): affected all versions; fixed in 6.2.8, 7.0.6
- keydb (Bitnami): affected all versions; fixed in 6.2.8, 7.0.6
- valkey (Bitnami): affected all versions; fixed in 6.2.8, 7.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3647/ (Markdown: https://insights.sbomify.com/CVE-2022-3647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3647
- OSV: https://osv.dev/vulnerability/CVE-2022-3647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3647/
Summaries are generated and may contain mistakes; the official description above is the record.
