# CVE-2022-36640: Missing authorization in n/a

> Unauthenticated attackers can execute arbitrary commands if authentication is not enabled, which is the default setting.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2022
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-influxdb-2022-36640, DEBIAN-CVE-2022-36640, GHSA-x7v4-5qjr-j62x

## What is CVE-2022-36640?

CVE-2022-36640 is a critical missing authorization vulnerability in n/a, published on 2 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

influxData influxDB before v1.8.10 contains no authentication mechanism or controls, allowing unauthenticated attackers to execute arbitrary commands. NOTE: the CVE ID assignment is disputed because the vendor's documentation states "If InfluxDB is being deployed on a publicly accessible endpoint, we strongly recommend authentication be enabled. Otherwise the data will be publicly available to any unauthenticated user. The default settings do NOT enable authentication and authorization."

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2022-36640?

1 open source package ship an affected version, including influxdb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `influxdb` | Bitnami | All versions | 1.8.0 |

Products: Influxdata Influxdb.

## How do I fix CVE-2022-36640?

Upgrade influxdb to 1.8.0 or later.

## Is CVE-2022-36640 being exploited?

There is no known exploitation of CVE-2022-36640 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-17572](https://insights.sbomify.com/CVE-2018-17572/): InfluxDB Reflected Cross-site Scripting (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36640 and fix it if it is affected.

What it is: CVE-2022-36640 is a critical missing authorization vulnerability in n/a, published on 2 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36640 in the wild and no public exploit code.

Affected packages and fixed versions:
- influxdb (Bitnami): affected all versions; fixed in 1.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36640/ (Markdown: https://insights.sbomify.com/CVE-2022-36640/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36640
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36640
- OSV: https://osv.dev/vulnerability/CVE-2022-36640

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36640/
Summaries are generated and may contain mistakes; the official description above is the record.
