# CVE-2022-36663: Gluu Oxauth before v4.4.1 vulnerable to Server-Side Request Forgery attacks via a crafted request_uri parameter

> Attackers can execute blind Server-Side Request Forgery attacks via a crafted request_uri parameter in Gluu Oxauth.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Sep 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hc94-9v26-gxwv

## What is CVE-2022-36663?

CVE-2022-36663 is a critical server-side request forgery vulnerability in n/a, published on 6 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gluu Oxauth before v4.4.1 allows attackers to execute blind SSRF (Server-Side Request Forgery) attacks via a crafted request_uri parameter.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2022-36663?

2 open source packages ship an affected version, including org.gluu:oxauth-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.gluu:oxauth-common` | Maven | All versions | 4.4.1 |
| `org.gluu:oxauth-common` | Maven | All versions | 4.4.1 |

Products: Gluu Oxauth.

## How do I fix CVE-2022-36663?

Upgrade org.gluu:oxauth-common to 4.4.1 or later.

## Is CVE-2022-36663 being exploited?

There is no known exploitation of CVE-2022-36663 in the wild and no public exploit code.

Public exploit code:

- Internal network scanner through Gluu IAM blind ssrf (github_poc): https://github.com/aqeisi/CVE-2022-36663-PoC

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36663 and fix it if it is affected.

What it is: CVE-2022-36663 is a critical server-side request forgery vulnerability in n/a, published on 6 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36663 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.gluu:oxauth-common (Maven): affected all versions; fixed in 4.4.1
- org.gluu:oxauth-common (Maven): affected all versions; fixed in 4.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36663/ (Markdown: https://insights.sbomify.com/CVE-2022-36663/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36663
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36663
- OSV: https://osv.dev/vulnerability/CVE-2022-36663

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36663/
Summaries are generated and may contain mistakes; the official description above is the record.
