# CVE-2022-36745: LibreNMS vulnerable to Cross-Site Scripting (XSS)

> An attacker can inject malicious scripts into LibreNMS via print-customoid.php, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5229-94p3-7wwq

## What is CVE-2022-36745?

CVE-2022-36745 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 30 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

LibreNMS v22.6.0 was discovered to contain a cross-site scripting (XSS) vulnerability via the component print-customoid.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-36745?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 22.7.0 |
| `librenms/librenms` | Packagist | All versions | 22.7.0 |

Products: Librenms Librenms.

## How do I fix CVE-2022-36745?

Upgrade librenms/librenms to 22.7.0 or later.

## Is CVE-2022-36745 being exploited?

There is no known exploitation of CVE-2022-36745 in the wild and no public exploit code.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36745 and fix it if it is affected.

What it is: CVE-2022-36745 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 30 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-36745 in the wild and no public exploit code.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 22.7.0
- librenms/librenms (Packagist): affected all versions; fixed in 22.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36745/ (Markdown: https://insights.sbomify.com/CVE-2022-36745/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36745
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36745
- OSV: https://osv.dev/vulnerability/CVE-2022-36745

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36745/
Summaries are generated and may contain mistakes; the official description above is the record.
