{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-36760 in the wild and no public exploit code.","fix":"Upgrade apache to 2.4.55 or later.","what":"CVE-2022-36760 is a critical vulnerability in Apache Http Server, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-36760 and fix it if it is affected.\n\nWhat it is: CVE-2022-36760 is a critical vulnerability in Apache Http Server, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-36760 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected from 2.4.0; fixed in 2.4.55\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36760/ (Markdown: https://insights.sbomify.com/CVE-2022-36760/index.md)","id":"CVE-2022-36760","markdown":"https://insights.sbomify.com/CVE-2022-36760/index.md","name":"CVE-2022-36760","record":{"aliases":["ALPINE-CVE-2022-36760","AZL-13027","BIT-apache-2022-36760","CLEANSTART-2026-VL60700","CLSA-2023-1675111279","CLSA-2023-1675111450","CLSA-2023-1675111607","CLSA-2023-1675111708","CLSA-2023-1675111939","CLSA-2026-1777033551","CLSA-2026-1778789558","CLSA-2026-1778789568","DEBIAN-CVE-2022-36760","GHSA-hwqh-57w6-xm49","UBUNTU-CVE-2022-36760"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache HTTP Server","requires_auth":"none","summary":"Attackers can smuggle requests to the AJP server via mod_proxy_ajp, potentially bypassing security controls or accessing unauthorized data.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"}],"cvss":{"score":9,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to.  This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.54 and prior versions.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache HTTP Server: mod_proxy_ajp Possible request smuggling","id":"CVE-2022-36760","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server"],"type":"other","year":"2022"},"n_packages":1,"n_references":2,"next":{"headline":"Heap Buffer Overflow in Tcg2MeasureGptTable","id":"CVE-2022-36763"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.55"],"introduced":["2.4.0"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2022-36760"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2022-36759"},"products":["Apache HTTP Server"],"published":"2023-01-17","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-04","vendors":["Apache Software Foundation"]},"summary":"Attackers can smuggle requests to the AJP server via mod_proxy_ajp, potentially bypassing security controls or accessing unauthorized data.","url":"https://insights.sbomify.com/CVE-2022-36760/"}