# CVE-2022-36760: Apache HTTP Server: mod_proxy_ajp Possible request smuggling

> Attackers can smuggle requests to the AJP server via mod_proxy_ajp, potentially bypassing security controls or accessing unauthorized data.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jan 2023
- **Updated:** 4 Apr 2025
- **Also known as:** ALPINE-CVE-2022-36760, AZL-13027, BIT-apache-2022-36760, CLEANSTART-2026-VL60700, CLSA-2023-1675111279, CLSA-2023-1675111450, CLSA-2023-1675111607, CLSA-2023-1675111708, CLSA-2023-1675111939, CLSA-2026-1777033551, CLSA-2026-1778789558, CLSA-2026-1778789568, DEBIAN-CVE-2022-36760, GHSA-hwqh-57w6-xm49, UBUNTU-CVE-2022-36760

## What is CVE-2022-36760?

CVE-2022-36760 is a critical vulnerability in Apache Http Server, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in mod_proxy_ajp of Apache HTTP Server allows an attacker to smuggle requests to the AJP server it forwards requests to.  This issue affects Apache HTTP Server Apache HTTP Server 2.4 version 2.4.54 and prior versions.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2022-36760?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | From 2.4.0 | 2.4.55 |

Products: Apache Http Server.

## How do I fix CVE-2022-36760?

Upgrade apache to 2.4.55 or later.

## Is CVE-2022-36760 being exploited?

There is no known exploitation of CVE-2022-36760 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36760 and fix it if it is affected.

What it is: CVE-2022-36760 is a critical vulnerability in Apache Http Server, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36760 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected from 2.4.0; fixed in 2.4.55

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36760/ (Markdown: https://insights.sbomify.com/CVE-2022-36760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36760
- OSV: https://osv.dev/vulnerability/CVE-2022-36760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36760/
Summaries are generated and may contain mistakes; the official description above is the record.
