# CVE-2022-36882: Lack of authentication mechanism in Jenkins Git Plugin webhook

> Attackers can exploit CSRF to trigger Jenkins builds using malicious Git repositories and commits, potentially leading to code execution or data modification.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-8xwj-2wgh-gprh

## What is CVE-2022-36882?

CVE-2022-36882 is a high-severity vulnerability in Jenkins Git Plugin, published on 27 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery (CSRF) vulnerability in Jenkins Git Plugin 4.11.3 and earlier allows attackers to trigger builds of jobs configured to use an attacker-specified Git repository and to cause them to check out an attacker-specified commit.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-36882?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:git. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:git` | Maven | All versions | 4.11.4 |
| `org.jenkins-ci.plugins:git` | Maven | All versions | 4.11.4 |

Products: Jenkins Git.

## How do I fix CVE-2022-36882?

Upgrade org.jenkins-ci.plugins:git to 4.11.4 or later.

## Is CVE-2022-36882 being exploited?

There is no known exploitation of CVE-2022-36882 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Git Plugin

- [CVE-2022-36883](https://insights.sbomify.com/CVE-2022-36883/): Lack of authentication mechanism in Jenkins Git Plugin webhook (high 7.5)
- [CVE-2022-30947](https://insights.sbomify.com/CVE-2022-30947/): Path traversal in Jenkins Git Mercurial and Repo Plugins (high 7.5)
- [CVE-2017-1000092](https://insights.sbomify.com/CVE-2017-1000092/): Cross-Site Request Forgery in Jenkins Git Plugin (high 7.5)
- [CVE-2022-38663](https://insights.sbomify.com/CVE-2022-38663/): Improper masking of credentials Jenkins in Git Plugin (medium 6.5)
- [CVE-2018-1000182](https://insights.sbomify.com/CVE-2018-1000182/): Server-Side Request Forgery in Jenkins Git Plugin (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36882 and fix it if it is affected.

What it is: CVE-2022-36882 is a high-severity vulnerability in Jenkins Git Plugin, published on 27 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-36882 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 4.11.4
- org.jenkins-ci.plugins:git (Maven): affected all versions; fixed in 4.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36882/ (Markdown: https://insights.sbomify.com/CVE-2022-36882/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36882
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36882
- OSV: https://osv.dev/vulnerability/CVE-2022-36882

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36882/
Summaries are generated and may contain mistakes; the official description above is the record.
