# CVE-2022-36885: Jenkins GitHub plugin uses weak webhook signature function

> Attackers can bypass webhook signature verification in the Jenkins GitHub Plugin using timing attacks to forge valid signatures.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-mxcc-7h5m-x57r

## What is CVE-2022-36885?

CVE-2022-36885 is a medium-severity vulnerability in Jenkins GitHub Plugin, published on 27 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins GitHub Plugin 1.34.4 and earlier uses a non-constant time comparison function when checking whether the provided and computed webhook signatures are equal, allowing attackers to use statistical methods to obtain a valid webhook signature.

Weakness: CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2022-36885?

2 open source packages ship an affected version, including com.coravy.hudson.plugins.github:github. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.coravy.hudson.plugins.github:github` | Maven | All versions | 1.34.5 |
| `com.coravy.hudson.plugins.github:github` | Maven | All versions | 1.34.5 |

Products: Jenkins Github.

## How do I fix CVE-2022-36885?

Upgrade com.coravy.hudson.plugins.github:github to 1.34.5 or later.

## Is CVE-2022-36885 being exploited?

There is no known exploitation of CVE-2022-36885 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins GitHub Plugin

- [CVE-2026-42523](https://insights.sbomify.com/CVE-2026-42523/): Jenkins GitHub Plugin has an XSS vulnerability (critical 9.0)
- [CVE-2018-1000600](https://insights.sbomify.com/CVE-2018-1000600/): CSRF vulnerability and missing permission checks in GitHub Plugin allowed capturing credentials (high 8.8)
- [CVE-2018-1000183](https://insights.sbomify.com/CVE-2018-1000183/): Jenkins GitHub Plugin exposure of sensitive information vulnerability exists (medium 6.5)
- [CVE-2023-46650](https://insights.sbomify.com/CVE-2023-46650/): Stored XSS vulnerability in Jenkins GitHub Plugin (medium 5.4)
- [CVE-2018-1000184](https://insights.sbomify.com/CVE-2018-1000184/): Jenkins GitHub Plugin server-side request forgery vulnerability exists (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36885 and fix it if it is affected.

What it is: CVE-2022-36885 is a medium-severity vulnerability in Jenkins GitHub Plugin, published on 27 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36885 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.coravy.hudson.plugins.github:github (Maven): affected all versions; fixed in 1.34.5
- com.coravy.hudson.plugins.github:github (Maven): affected all versions; fixed in 1.34.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36885/ (Markdown: https://insights.sbomify.com/CVE-2022-36885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36885
- OSV: https://osv.dev/vulnerability/CVE-2022-36885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36885/
Summaries are generated and may contain mistakes; the official description above is the record.
