# CVE-2022-36900: Jenkins Compuware zAdviser API Plugin vulnerable to protection mechanism failure

> Attackers controlling agent processes can retrieve Java system properties due to missing restrictions on controller/agent message execution in the Jenkins Compuware zAdviser API Plugin.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-5xp2-7qfc-fwgc

## What is CVE-2022-36900?

CVE-2022-36900 is a high-severity vulnerability in Jenkins Compuware zAdviser API Plugin, published on 27 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Compuware zAdviser API Plugin 1.0.3 and earlier does not restrict execution of a controller/agent message to agents, allowing attackers able to control agent processes to retrieve Java system properties.

## Which versions are affected by CVE-2022-36900?

2 open source packages ship an affected version, including com.compuware.jenkins:compuware-zadviser-api. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.compuware.jenkins:compuware-zadviser-api` | Maven | All versions | 1.0.4 |
| `com.compuware.jenkins:compuware-zadviser-api` | Maven | All versions | 1.0.4 |

Products: Jenkins Compuware Zadviser Api.

## How do I fix CVE-2022-36900?

Upgrade com.compuware.jenkins:compuware-zadviser-api to 1.0.4 or later.

## Is CVE-2022-36900 being exploited?

There is no known exploitation of CVE-2022-36900 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-36900 and fix it if it is affected.

What it is: CVE-2022-36900 is a high-severity vulnerability in Jenkins Compuware zAdviser API Plugin, published on 27 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-36900 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.compuware.jenkins:compuware-zadviser-api (Maven): affected all versions; fixed in 1.0.4
- com.compuware.jenkins:compuware-zadviser-api (Maven): affected all versions; fixed in 1.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-36900/ (Markdown: https://insights.sbomify.com/CVE-2022-36900/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-36900
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-36900
- OSV: https://osv.dev/vulnerability/CVE-2022-36900

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-36900/
Summaries are generated and may contain mistakes; the official description above is the record.
