{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:http_request. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-36901 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:http_request to 1.16 or later.","what":"CVE-2022-36901 is a medium-severity vulnerability in Jenkins HTTP Request Plugin, published on 27 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-36901 and fix it if it is affected.\n\nWhat it is: CVE-2022-36901 is a medium-severity vulnerability in Jenkins HTTP Request Plugin, published on 27 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-36901 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:http_request (Maven): affected all versions; fixed in 1.16\n- org.jenkins-ci.plugins:http_request (Maven): affected all versions; fixed in 1.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-36901/ (Markdown: https://insights.sbomify.com/CVE-2022-36901/index.md)","id":"CVE-2022-36901","markdown":"https://insights.sbomify.com/CVE-2022-36901/index.md","name":"CVE-2022-36901","record":{"aliases":["GHSA-2qh6-hhvv-m2ww"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins HTTP Request Plugin","requires_auth":"low_privilege","summary":"Attackers with Jenkins controller file system access can view unencrypted HTTP Request passwords stored in the global configuration file.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"http_request","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"Jenkins HTTP Request Plugin 1.15 and earlier stores HTTP Request passwords unencrypted in its global configuration file on the Jenkins controller where they can be viewed by users with access to the Jenkins controller file system.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins HTTP Request Plugin stores HTTP Request passwords unencrypted","id":"CVE-2022-36901","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Stored XSS vulnerability in Jenkins Dynamic Extended Choice Parameter plugin","id":"CVE-2022-36902"},"packages":[{"ecosystem":"Maven","fixed":["1.16"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:http_request","purl":null,"source":"GHSA-2qh6-hhvv-m2ww"},{"ecosystem":"Maven","fixed":["1.16"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:http_request","purl":"pkg:maven/org.jenkins-ci.plugins/http_request","source":"GHSA-2qh6-hhvv-m2ww"}],"prev":{"headline":"Jenkins Compuware zAdviser API Plugin vulnerable to protection mechanism failure","id":"CVE-2022-36900"},"products":["Jenkins HTTP Request Plugin"],"published":"2022-07-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Jenkins project"]},"summary":"Attackers with Jenkins controller file system access can view unencrypted HTTP Request passwords stored in the global configuration file.","url":"https://insights.sbomify.com/CVE-2022-36901/"}