# CVE-2022-3697: Ansible leaks password to logs

> An attacker can read leaked passwords from logs due to insecure handling of the tower_callback parameter in the Ansible amazon.aws ec2_instance module.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2022
- **Updated:** 13 Feb 2025
- **Also known as:** CLSA-2023-1691083401, DEBIAN-CVE-2022-3697, GHSA-cpx3-93w7-457x, PYSEC-2026-768, UBUNTU-CVE-2022-3697

## What is CVE-2022-3697?

CVE-2022-3697 is a high-severity vulnerability in ansible, ansible community.aws, ansible amazon.aws, published on 28 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in Ansible in the amazon.aws collection when using the tower_callback parameter from the amazon.aws.ec2_instance module. This flaw allows an attacker to take advantage of this issue as the module is handling the parameter insecurely, leading to the password leaking in the logs.

Weakness: CWE-233 (Improper Handling of Parameters)

## Which versions are affected by CVE-2022-3697?

3 open source packages ship an affected version, including ansible. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | From 2.5.0 | 7.0.0 |
| `ansible` | PyPI | From 2.5.0 | 7.0.0 |
| `ansible` | PyPI | From 2.5.0 | 7.0.0 |

Products: Redhat Ansible, Redhat Ansible Collection.

## How do I fix CVE-2022-3697?

Upgrade ansible to 7.0.0 or later.

## Is CVE-2022-3697 being exploited?

There is no known exploitation of CVE-2022-3697 in the wild and no public exploit code.

## Other vulnerabilities in ansible, ansible community.aws, ansible amazon.aws

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-4967](https://insights.sbomify.com/CVE-2014-4967/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2017-7550](https://insights.sbomify.com/CVE-2017-7550/): Ansible Insertion of Sensitive Information into Log File vulnerability (critical 9.8)
- [CVE-2014-3498](https://insights.sbomify.com/CVE-2014-3498/): Ansible Arbitrary Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3697 and fix it if it is affected.

What it is: CVE-2022-3697 is a high-severity vulnerability in ansible, ansible community.aws, ansible amazon.aws, published on 28 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-3697 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected from 2.5.0; fixed in 7.0.0
- ansible (PyPI): affected from 2.5.0; fixed in 7.0.0
- ansible (PyPI): affected from 2.5.0; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3697/ (Markdown: https://insights.sbomify.com/CVE-2022-3697/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3697
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3697
- OSV: https://osv.dev/vulnerability/CVE-2022-3697

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3697/
Summaries are generated and may contain mistakes; the official description above is the record.
