CVE-2022-37021 Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8.
Attackers can execute arbitrary code via deserialization flaws in Apache Geode when using JMX over RMI on Java 8.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-37021?
CVE-2022-37021 is a critical unsafe deserialization vulnerability in Apache Geode, published on 31 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify "--J=-Dgeode.enableGlobalSerialFilter=true" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the "serializable-object-filter" configuration option. Using a global serial filter will impact performance.
Weakness: CWE-502
Which versions are affected by CVE-2022-37021?
6 open source packages ship an affected version, including org.apache.geode:geode-core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.geode:geode-core Maven | All versions | 1.12.16 |
org.apache.geode:geode-core Maven | All versions | 1.12.16 |
org.apache.geode:geode-core Maven | From 1.13.0 | 1.13.5 |
org.apache.geode:geode-core Maven | From 1.13.0 | 1.13.5 |
org.apache.geode:geode-core Maven | From 1.14.0 | 1.14.1 |
org.apache.geode:geode-core Maven | From 1.14.0 | 1.14.1 |
Products include Apache Geode.
How do I fix CVE-2022-37021?
Upgrade org.apache.geode:geode-core to a fixed version for your release line: 1.12.16, 1.13.5 or 1.14.1.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2022-37021 being exploited?
There is no known exploitation of CVE-2022-37021 in the wild and no public exploit code.
Other vulnerabilities in Apache Geode
- CVE-2020-1938 Apache Tomcat Improper Privilege Management
- CVE-2019-15752 Docker Desktop Community Edition Privilege Escalation
- CVE-2014-0048 Supply chain in docker.io
- CVE-2017-15692 Apache Geode unsafe deserialization in TcpServer
- CVE-2025-47410 Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system
Sources
Also known as GHSA-q4q3-r45f-7gwg.