{"answers":{"affected":"6 open source packages ship an affected version, including org.apache.geode:geode-core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-37021 in the wild and no public exploit code.","fix":"Upgrade org.apache.geode:geode-core to a fixed version for your release line: 1.12.16, 1.13.5 or 1.14.1.","what":"CVE-2022-37021 is a critical unsafe deserialization vulnerability in Apache Geode, published on 31 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-37021 and fix it if it is affected.\n\nWhat it is: CVE-2022-37021 is a critical unsafe deserialization vulnerability in Apache Geode, published on 31 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-37021 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.geode:geode-core (Maven): affected all versions; fixed in 1.12.16\n- org.apache.geode:geode-core (Maven): affected all versions; fixed in 1.12.16\n- org.apache.geode:geode-core (Maven): affected from 1.13.0; fixed in 1.13.5\n- org.apache.geode:geode-core (Maven): affected from 1.13.0; fixed in 1.13.5\n- org.apache.geode:geode-core (Maven): affected from 1.14.0; fixed in 1.14.1\n- org.apache.geode:geode-core (Maven): affected from 1.14.0; fixed in 1.14.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-37021/ (Markdown: https://insights.sbomify.com/CVE-2022-37021/index.md)","id":"CVE-2022-37021","markdown":"https://insights.sbomify.com/CVE-2022-37021/index.md","name":"CVE-2022-37021","record":{"aliases":["GHSA-q4q3-r45f-7gwg"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Geode","requires_auth":"none","summary":"Attackers can execute arbitrary code via deserialization flaws in Apache Geode when using JMX over RMI on Java 8.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"geode","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify \"--J=-Dgeode.enableGlobalSerialFilter=true\" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the \"serializable-object-filter\" configuration option. Using a global serial filter will impact performance.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8.","id":"CVE-2022-37021","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2022"},"n_packages":6,"n_references":1,"next":{"headline":"Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 11","id":"CVE-2022-37022"},"packages":[{"ecosystem":"Maven","fixed":["1.12.16"],"introduced":["0"],"last_affected":[],"package":"org.apache.geode:geode-core","purl":null,"source":"GHSA-q4q3-r45f-7gwg"},{"ecosystem":"Maven","fixed":["1.12.16"],"introduced":["0"],"last_affected":[],"package":"org.apache.geode:geode-core","purl":"pkg:maven/org.apache.geode/geode-core","source":"GHSA-q4q3-r45f-7gwg"},{"ecosystem":"Maven","fixed":["1.13.5"],"introduced":["1.13.0"],"last_affected":[],"package":"org.apache.geode:geode-core","purl":null,"source":"GHSA-q4q3-r45f-7gwg"},{"ecosystem":"Maven","fixed":["1.13.5"],"introduced":["1.13.0"],"last_affected":[],"package":"org.apache.geode:geode-core","purl":"pkg:maven/org.apache.geode/geode-core","source":"GHSA-q4q3-r45f-7gwg"},{"ecosystem":"Maven","fixed":["1.14.1"],"introduced":["1.14.0"],"last_affected":[],"package":"org.apache.geode:geode-core","purl":null,"source":"GHSA-q4q3-r45f-7gwg"},{"ecosystem":"Maven","fixed":["1.14.1"],"introduced":["1.14.0"],"last_affected":[],"package":"org.apache.geode:geode-core","purl":"pkg:maven/org.apache.geode/geode-core","source":"GHSA-q4q3-r45f-7gwg"}],"prev":{"headline":"HP PC BIOS May 2024 Security Updates for Potential Stack Buffer Overflows","id":"CVE-2022-37020"},"products":["Apache Geode"],"published":"2022-08-31","related":[{"cvss_score":9.8,"headline":"Apache Tomcat Improper Privilege Management","id":"CVE-2020-1938","kev_date_added":"2022-03-03","published":"2020-02-24"},{"cvss_score":7.8,"headline":"Docker Desktop Community Edition Privilege Escalation","id":"CVE-2019-15752","kev_date_added":"2021-11-03","published":"2019-08-28"},{"cvss_score":9.8,"headline":"Supply chain in docker.io","id":"CVE-2014-0048","kev_date_added":null,"published":"2020-01-02"},{"cvss_score":9.8,"headline":"Apache Geode unsafe deserialization in TcpServer","id":"CVE-2017-15692","kev_date_added":null,"published":"2018-02-27"},{"cvss_score":8.8,"headline":"Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system","id":"CVE-2025-47410","kev_date_added":null,"published":"2025-10-18"},{"cvss_score":8.8,"headline":"Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 11","id":"CVE-2022-37022","kev_date_added":null,"published":"2022-08-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary code via deserialization flaws in Apache Geode when using JMX over RMI on Java 8.","url":"https://insights.sbomify.com/CVE-2022-37021/"}