# CVE-2022-37021: Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8.

> Attackers can execute arbitrary code via deserialization flaws in Apache Geode when using JMX over RMI on Java 8.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-q4q3-r45f-7gwg

## What is CVE-2022-37021?

CVE-2022-37021 is a critical unsafe deserialization vulnerability in Apache Geode, published on 31 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify "--J=-Dgeode.enableGlobalSerialFilter=true" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the "serializable-object-filter" configuration option. Using a global serial filter will impact performance.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-37021?

6 open source packages ship an affected version, including org.apache.geode:geode-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.geode:geode-core` | Maven | All versions | 1.12.16 |
| `org.apache.geode:geode-core` | Maven | All versions | 1.12.16 |
| `org.apache.geode:geode-core` | Maven | From 1.13.0 | 1.13.5 |
| `org.apache.geode:geode-core` | Maven | From 1.13.0 | 1.13.5 |
| `org.apache.geode:geode-core` | Maven | From 1.14.0 | 1.14.1 |
| `org.apache.geode:geode-core` | Maven | From 1.14.0 | 1.14.1 |

Products: Apache Geode.

## How do I fix CVE-2022-37021?

Upgrade org.apache.geode:geode-core to a fixed version for your release line: 1.12.16, 1.13.5 or 1.14.1.

## Is CVE-2022-37021 being exploited?

There is no known exploitation of CVE-2022-37021 in the wild and no public exploit code.

## Other vulnerabilities in Apache Geode

- [CVE-2020-1938](https://insights.sbomify.com/CVE-2020-1938/): Apache Tomcat Improper Privilege Management (critical 9.8, exploited in the wild)
- [CVE-2019-15752](https://insights.sbomify.com/CVE-2019-15752/): Docker Desktop Community Edition Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2014-0048](https://insights.sbomify.com/CVE-2014-0048/): Supply chain in docker.io (critical 9.8)
- [CVE-2017-15692](https://insights.sbomify.com/CVE-2017-15692/): Apache Geode unsafe deserialization in TcpServer (critical 9.8)
- [CVE-2025-47410](https://insights.sbomify.com/CVE-2025-47410/): Apache Geode: CSRF attacks through GET requests to the Management and Monitoring REST API that can execute gfsh commands on the target system (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-37021 and fix it if it is affected.

What it is: CVE-2022-37021 is a critical unsafe deserialization vulnerability in Apache Geode, published on 31 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-37021 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.geode:geode-core (Maven): affected all versions; fixed in 1.12.16
- org.apache.geode:geode-core (Maven): affected all versions; fixed in 1.12.16
- org.apache.geode:geode-core (Maven): affected from 1.13.0; fixed in 1.13.5
- org.apache.geode:geode-core (Maven): affected from 1.13.0; fixed in 1.13.5
- org.apache.geode:geode-core (Maven): affected from 1.14.0; fixed in 1.14.1
- org.apache.geode:geode-core (Maven): affected from 1.14.0; fixed in 1.14.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-37021/ (Markdown: https://insights.sbomify.com/CVE-2022-37021/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-37021
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-37021
- OSV: https://osv.dev/vulnerability/CVE-2022-37021

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-37021/
Summaries are generated and may contain mistakes; the official description above is the record.
