CVE-2022-37022 Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 11

High 8.8 Published Updated

Attackers can execute arbitrary code via deserialization flaws in Apache Geode when using JMX over RMI on Java 11.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-37022?

CVE-2022-37022 is a high-severity unsafe deserialization vulnerability in Apache Geode, published on 31 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache Geode versions up to 1.12.2 and 1.13.2 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 11. Any user wishing to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15. Use of 1.15 on Java 11 will automatically protect JMX over RMI against deserialization attacks. This should have no impact on performance since it only affects JMX/RMI which Gfsh uses to communicate with the JMX Manager which is hosted on a Locator.

Weakness: CWE-502

Which versions are affected by CVE-2022-37022?

2 open source packages ship an affected version, including org.apache.geode:geode-core. It affects 1 product.

PackageAffectedFixed in
org.apache.geode:geode-core MavenAll versions1.15.0
org.apache.geode:geode-core MavenAll versions1.15.0

Products include Apache Geode.

How do I fix CVE-2022-37022?

Upgrade org.apache.geode:geode-core to 1.15.0 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2022-37022 being exploited?

There is no known exploitation of CVE-2022-37022 in the wild and no public exploit code.

Sources

Also known as GHSA-qf8g-vpwp-6579.

Is CVE-2022-37022 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free