CVE-2022-37023 Apache Geode deserialization of untrusted data flaw when using REST API on Java 8 or Java 11

Medium 6.5 Published Updated

Attackers can execute arbitrary code via deserialization flaws in Apache Geode REST APIs on Java 8 or 11.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-37023?

CVE-2022-37023 is a medium-severity unsafe deserialization vulnerability in Apache Geode, published on 31 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.

Weakness: CWE-502

Which versions are affected by CVE-2022-37023?

2 open source packages ship an affected version, including org.apache.geode:geode-core. It affects 1 product.

PackageAffectedFixed in
org.apache.geode:geode-core MavenAll versions1.15.0
org.apache.geode:geode-core MavenAll versions1.15.0

Products include Apache Geode.

How do I fix CVE-2022-37023?

Upgrade org.apache.geode:geode-core to 1.15.0 or later.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2022-37023 being exploited?

There is no known exploitation of CVE-2022-37023 in the wild and no public exploit code.

Sources

Also known as GHSA-72x9-48mc-phh6.

Is CVE-2022-37023 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free