CVE-2022-37247 Craft CMS vulnerable to stored Cross-site Scripting via /admin/settings/fields page
Attackers can inject malicious scripts into Craft CMS admin settings, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-37247?
CVE-2022-37247 is a medium-severity cross-site scripting vulnerability in Craftcms Craft Cms, published on 16 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Craft CMS 4.2.0.1 is vulnerable to stored a cross-site scripting (XSS) via /admin/settings/fields page.
Weakness: CWE-79
Which versions are affected by CVE-2022-37247?
2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.2.1 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.2.1 |
Products include Craftcms Craft Cms.
How do I fix CVE-2022-37247?
Upgrade craftcms/cms to 4.2.1 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-37247 being exploited?
There is no known exploitation of CVE-2022-37247 in the wild and no public exploit code.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-3cvm-7wrh-qrf9.