CVE-2022-37248 Craft CMS Cross site Scripting vulnerability
Cross-site scripting vulnerability in Craft CMS allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-37248?
CVE-2022-37248 is a medium-severity cross-site scripting vulnerability in Craftcms Craft Cms, published on 16 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Craft CMS 4.2.0.1 is vulnerable to Cross Site Scripting (XSS) via src/helpers/Cp.php.
Weakness: CWE-79
Which versions are affected by CVE-2022-37248?
2 open source packages ship an affected version, including craftcms/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.2.1 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.2.1 |
Products include Craftcms Craft Cms.
How do I fix CVE-2022-37248?
Upgrade craftcms/cms to 4.2.1 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-37248 being exploited?
There is no known exploitation of CVE-2022-37248 in the wild and no public exploit code.
Other vulnerabilities in Craftcms Craft Cms
Sources
Also known as GHSA-wxvf-839f-jqmh.