# CVE-2022-37315: graphql-go has infinite recursion in the type definition parser

> An attacker can cause a denial of service via infinite recursion in the type definition parser of the graphql-go library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-h3qm-jrrf-cgj3, GO-2022-0942, UBUNTU-CVE-2022-37315

## What is CVE-2022-37315?

CVE-2022-37315 is a high-severity denial of service vulnerability in n/a, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

graphql-go (aka GraphQL for Go) through 0.8.0 has infinite recursion in the type definition parser.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2022-37315?

3 open source packages ship an affected version, including github.com/graphql-go/graphql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/graphql-go/graphql` | Go | All versions | 0.8.1 |
| `github.com/graphql-go/graphql` | Go | All versions | 0.8.1 |
| `github.com/graphql-go/graphql` | Go | All versions | 0.8.1 |

Products: Graphql-Go Project Graphql-Go.

## How do I fix CVE-2022-37315?

Upgrade github.com/graphql-go/graphql to 0.8.1 or later.

## Is CVE-2022-37315 being exploited?

There is no known exploitation of CVE-2022-37315 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-21708](https://insights.sbomify.com/CVE-2022-21708/): Denial of Service in graphql-go (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-37315 and fix it if it is affected.

What it is: CVE-2022-37315 is a high-severity denial of service vulnerability in n/a, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-37315 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/graphql-go/graphql (Go): affected all versions; fixed in 0.8.1
- github.com/graphql-go/graphql (Go): affected all versions; fixed in 0.8.1
- github.com/graphql-go/graphql (Go): affected all versions; fixed in 0.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-37315/ (Markdown: https://insights.sbomify.com/CVE-2022-37315/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-37315
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-37315
- OSV: https://osv.dev/vulnerability/CVE-2022-37315

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-37315/
Summaries are generated and may contain mistakes; the official description above is the record.
