# CVE-2022-37333: exceedone/exment and exceedone/laravel-admin SQL Injection vulnerability

> Remote authenticated attackers can execute arbitrary SQL commands in Exment, potentially accessing or modifying sensitive data.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-p74q-2pf8-j5jx

## What is CVE-2022-37333?

CVE-2022-37333 is a high-severity SQL injection vulnerability in Kajitori Co.,Ltd Exment, published on 24 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

SQL injection vulnerability in the Exment ((PHP8) exceedone/exment v5.0.2 and earlier and exceedone/laravel-admin v3.0.0 and earlier, (PHP7) exceedone/exment v4.4.2 and earlier and exceedone/laravel-admin v2.2.2 and earlier) allows remote authenticated attackers to execute arbitrary SQL commands.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-37333?

8 open source packages ship an affected version, including exceedone/exment and exceedone/laravel-admin. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `exceedone/exment` | Packagist | All versions | 4.4.3 |
| `exceedone/exment` | Packagist | All versions | 4.4.3 |
| `exceedone/exment` | Packagist | From 5.0.0 | 5.0.3 |
| `exceedone/exment` | Packagist | From 5.0.0 | 5.0.3 |
| `exceedone/laravel-admin` | Packagist | All versions | 2.2.3 |
| `exceedone/laravel-admin` | Packagist | All versions | 2.2.3 |
| `exceedone/laravel-admin` | Packagist | From 3.0.0 | 3.0.1 |
| `exceedone/laravel-admin` | Packagist | From 3.0.0 | 3.0.1 |

Products: Exceedone Exment, Exceedone Laravel-Admin.

## How do I fix CVE-2022-37333?

Upgrade exceedone/exment to a fixed version for your release line: 4.4.3 or 5.0.3.

## Is CVE-2022-37333 being exploited?

There is no known exploitation of CVE-2022-37333 in the wild and no public exploit code.

## Other vulnerabilities in Kajitori Co.,Ltd Exment

- [CVE-2024-47793](https://insights.sbomify.com/CVE-2024-47793/): Cross-site scripting in Exment (medium 5.4)
- [CVE-2022-38080](https://insights.sbomify.com/CVE-2022-38080/): exceedone/exment and exceedone/laravel-admin Cross-site Scripting vulnerability (medium 5.4)
- [CVE-2022-38089](https://insights.sbomify.com/CVE-2022-38089/): Cross-site scripting in Exment (medium 5.4)
- [CVE-2020-5619](https://insights.sbomify.com/CVE-2020-5619/): Cross-site scripting in Exment (medium 5.4)
- [CVE-2020-5620](https://insights.sbomify.com/CVE-2020-5620/): Cross-site scripting in Exment (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-37333 and fix it if it is affected.

What it is: CVE-2022-37333 is a high-severity SQL injection vulnerability in Kajitori Co.,Ltd Exment, published on 24 Aug 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-37333 in the wild and no public exploit code.

Affected packages and fixed versions:
- exceedone/exment (Packagist): affected all versions; fixed in 4.4.3
- exceedone/exment (Packagist): affected all versions; fixed in 4.4.3
- exceedone/exment (Packagist): affected from 5.0.0; fixed in 5.0.3
- exceedone/exment (Packagist): affected from 5.0.0; fixed in 5.0.3
- exceedone/laravel-admin (Packagist): affected all versions; fixed in 2.2.3
- exceedone/laravel-admin (Packagist): affected all versions; fixed in 2.2.3
- exceedone/laravel-admin (Packagist): affected from 3.0.0; fixed in 3.0.1
- exceedone/laravel-admin (Packagist): affected from 3.0.0; fixed in 3.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-37333/ (Markdown: https://insights.sbomify.com/CVE-2022-37333/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-37333
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-37333
- OSV: https://osv.dev/vulnerability/CVE-2022-37333

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-37333/
Summaries are generated and may contain mistakes; the official description above is the record.
