# CVE-2022-37394: OpenStack Nova Changing vnic_type breaks compute service restart

> An authenticated user can cause compute service failure by manipulating neutron port vnic types, leading to denial of service in SR-IOV deployments.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-37394, GHSA-v725-c588-h936, PYSEC-2026-882, RHSA-2023:1948, UBUNTU-CVE-2022-37394

## What is CVE-2022-37394?

CVE-2022-37394 is a low-severity denial of service vulnerability in n/a, published on 3 Aug 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in OpenStack Nova before 23.2.2, 24.x before 24.1.2, and 25.x before 25.0.2. By creating a neutron port with the direct vnic_type, creating an instance bound to that port, and then changing the vnic_type of the bound port to macvtap, an authenticated user may cause the compute service to fail to restart, resulting in a possible denial of service. Only Nova deployments configured with SR-IOV are affected.

## Which versions are affected by CVE-2022-37394?

7 open source packages ship an affected version, including nova. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nova` | PyPI | All versions | 23.2.2, 24.1.2, 25.0.2 |
| `nova` | PyPI | All versions | 23.2.2 |
| `nova` | PyPI | All versions | 23.2.2 |
| `nova` | PyPI | From 24.0.0 | 24.1.2 |
| `nova` | PyPI | From 24.0.0 | 24.1.2 |
| `nova` | PyPI | From 25.0.0 | 25.0.2 |
| `nova` | PyPI | From 25.0.0 | 25.0.2 |
| `openstack-nova` | Red Hat:openstack:16.2::el8 | All versions | 1:20.6.2-2.20230308185148.fc01371.el8ost |

Products: Openstack Nova.

## How do I fix CVE-2022-37394?

Upgrade nova to a fixed version for your release line: 23.2.2, 24.1.2 or 25.0.2.

## Is CVE-2022-37394 being exploited?

There is no known exploitation of CVE-2022-37394 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-7214](https://insights.sbomify.com/CVE-2017-7214/): OpenStack Nova logs sensitive context from notification exceptions (critical 9.8)
- [CVE-2017-17051](https://insights.sbomify.com/CVE-2017-17051/): OpenStack Nova DoS by rebuilding the same instance with a new image multiple times (high 8.6)
- [CVE-2020-17376](https://insights.sbomify.com/CVE-2020-17376/): OpenStack Nova Live migration fails to update persistent domain XML (high 8.3)
- [CVE-2017-18191](https://insights.sbomify.com/CVE-2017-18191/): OpenStack Nova Denial of service attack on the compute host (high 7.5)
- [CVE-2015-3280](https://insights.sbomify.com/CVE-2015-3280/): OpenStack Compute (nova) allows remote authenticated users to cause a denial of service (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-37394 and fix it if it is affected.

What it is: CVE-2022-37394 is a low-severity denial of service vulnerability in n/a, published on 3 Aug 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-37394 in the wild and no public exploit code.

Affected packages and fixed versions:
- nova (PyPI): affected all versions; fixed in 23.2.2, 24.1.2, 25.0.2
- nova (PyPI): affected all versions; fixed in 23.2.2
- nova (PyPI): affected all versions; fixed in 23.2.2
- nova (PyPI): affected from 24.0.0; fixed in 24.1.2
- nova (PyPI): affected from 24.0.0; fixed in 24.1.2
- nova (PyPI): affected from 25.0.0; fixed in 25.0.2
- nova (PyPI): affected from 25.0.0; fixed in 25.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-37394/ (Markdown: https://insights.sbomify.com/CVE-2022-37394/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-37394
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-37394
- OSV: https://osv.dev/vulnerability/CVE-2022-37394

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-37394/
Summaries are generated and may contain mistakes; the official description above is the record.
