CVE-2022-3740 Auth bypass in GitLab

Medium 6.5 Published Updated

A group owner can bypass External Authorization checks to access git repositories and package registries using deploy tokens or keys.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-3740?

CVE-2022-3740 is a medium-severity authentication bypass vulnerability in Gitlab Gitlab, published on 24 Jan 2023. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 12.9 prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2. A group owner may be able to bypass External Authorization check, if it is enabled, to access git repositories and package registries by using Deploy tokens or Deploy keys .

Weakness: CWE-285

Which versions are affected by CVE-2022-3740?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 12.9.015.4.6, 15.5.5, 15.6.1

Products include Gitlab Gitlab.

How do I fix CVE-2022-3740?

Upgrade gitlab to a fixed version for your release line: 15.4.6, 15.5.5 or 15.6.1.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2022-3740 being exploited?

There is no known exploitation of CVE-2022-3740 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-3740, GHSA-52w5-6rqq-mwq5, UBUNTU-CVE-2022-3740.

Is CVE-2022-3740 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free