# CVE-2022-37423: Neo4j Graph apoc plugins Partial Path Traversal Vulnerability

> Attackers can read files from sibling directories via the apoc.log.stream procedure in Neo4j APOC, potentially exposing sensitive data.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-78f9-745f-278p

## What is CVE-2022-37423?

CVE-2022-37423 is a high-severity path traversal vulnerability in n/a, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Neo4j APOC (Awesome Procedures on Cypher) before 4.3.0.7 and 4.x before 4.4.0.8 allows Directory Traversal to sibling directories via apoc.log.stream.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-37423?

4 open source packages ship an affected version, including org.neo4j.procedure:apoc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.neo4j.procedure:apoc` | Maven | All versions | 4.3.0.7 |
| `org.neo4j.procedure:apoc` | Maven | All versions | 4.3.0.7 |
| `org.neo4j.procedure:apoc` | Maven | From 4.4.0.0 | 4.4.0.8 |
| `org.neo4j.procedure:apoc` | Maven | From 4.4.0.0 | 4.4.0.8 |

Products: Neo4j Awesome Procedures on Cypher.

## How do I fix CVE-2022-37423?

Upgrade org.neo4j.procedure:apoc to a fixed version for your release line: 4.3.0.7 or 4.4.0.8.

## Is CVE-2022-37423 being exploited?

There is no known exploitation of CVE-2022-37423 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-37423 and fix it if it is affected.

What it is: CVE-2022-37423 is a high-severity path traversal vulnerability in n/a, published on 12 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-37423 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.neo4j.procedure:apoc (Maven): affected all versions; fixed in 4.3.0.7
- org.neo4j.procedure:apoc (Maven): affected all versions; fixed in 4.3.0.7
- org.neo4j.procedure:apoc (Maven): affected from 4.4.0.0; fixed in 4.4.0.8
- org.neo4j.procedure:apoc (Maven): affected from 4.4.0.0; fixed in 4.4.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-37423/ (Markdown: https://insights.sbomify.com/CVE-2022-37423/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-37423
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-37423
- OSV: https://osv.dev/vulnerability/CVE-2022-37423

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-37423/
Summaries are generated and may contain mistakes; the official description above is the record.
