{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.shenyu:shenyu-common. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-37435 in the wild and no public exploit code.","fix":"Upgrade org.apache.shenyu:shenyu-common to 2.5.0 or later.","what":"CVE-2022-37435 is a high-severity vulnerability in Apache ShenYu, published on 1 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-37435 and fix it if it is affected.\n\nWhat it is: CVE-2022-37435 is a high-severity vulnerability in Apache ShenYu, published on 1 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-37435 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.shenyu:shenyu-common (Maven): affected from 2.4.2; fixed in 2.5.0\n- org.apache.shenyu:shenyu-common (Maven): affected from 2.4.2; fixed in 2.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-37435/ (Markdown: https://insights.sbomify.com/CVE-2022-37435/index.md)","id":"CVE-2022-37435","markdown":"https://insights.sbomify.com/CVE-2022-37435/index.md","name":"CVE-2022-37435","record":{"aliases":["GHSA-fjjw-82xw-vfc2"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ShenYu Admin","requires_auth":"low_privilege","summary":"Low-privilege administrators can modify high-privilege administrator passwords, leading to privilege escalation and account takeover in Apache ShenYu Admin.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"shenyu","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-732","name":"Incorrect Permission Assignment for Critical Resource"}],"description":"Apache ShenYu Admin has insecure permissions, which may allow low-privilege administrators to modify high-privilege administrator's passwords. This issue affects Apache ShenYu 2.4.2 and 2.4.3.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache ShenYu Admin Improper Privilege Management","id":"CVE-2022-37435","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"privilege_escalation","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Apache HTTP Server: mod_proxy prior to 2.4.55 allows a backend to trigger HTTP response splitting","id":"CVE-2022-37436"},"packages":[{"ecosystem":"Maven","fixed":["2.5.0"],"introduced":["2.4.2"],"last_affected":[],"package":"org.apache.shenyu:shenyu-common","purl":null,"source":"GHSA-fjjw-82xw-vfc2"},{"ecosystem":"Maven","fixed":["2.5.0"],"introduced":["2.4.2"],"last_affected":[],"package":"org.apache.shenyu:shenyu-common","purl":"pkg:maven/org.apache.shenyu/shenyu-common","source":"GHSA-fjjw-82xw-vfc2"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2022-37434"},"products":["Apache ShenYu"],"published":"2022-09-01","related":[{"cvss_score":9.8,"headline":"Apache ShenYu 2.4.1 Groovy Code Injection \u0026 SpEL Injection","id":"CVE-2021-45029","kev_date_added":null,"published":"2022-01-25"},{"cvss_score":9.8,"headline":"Apache ShenYu Admin bypass JWT authentication","id":"CVE-2021-37580","kev_date_added":null,"published":"2021-11-16"},{"cvss_score":9.1,"headline":"Apache ShenYu 2.4.1 Improper access control","id":"CVE-2022-23944","kev_date_added":null,"published":"2022-01-25"},{"cvss_score":8.8,"headline":"Apache ShenYu Admin ultra vires","id":"CVE-2022-42735","kev_date_added":null,"published":"2023-02-15"},{"cvss_score":7.5,"headline":"Apache ShenYu (incubating) Regular expression denial of service","id":"CVE-2022-26650","kev_date_added":null,"published":"2022-05-17"},{"cvss_score":7.5,"headline":"Apache ShenYu Password leakage","id":"CVE-2022-23223","kev_date_added":null,"published":"2022-01-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Apache Software Foundation"]},"summary":"Low-privilege administrators can modify high-privilege administrator passwords, leading to privilege escalation and account takeover in Apache ShenYu Admin.","url":"https://insights.sbomify.com/CVE-2022-37435/"}