# CVE-2022-37436: Apache HTTP Server: mod_proxy prior to 2.4.55 allows a backend to trigger HTTP response splitting

> A malicious backend can truncate response headers, causing security headers to be ignored by clients, potentially bypassing security controls.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jan 2023
- **Updated:** 4 Apr 2025
- **Also known as:** ALPINE-CVE-2022-37436, AZL-13167, AZL-43456, AZL-45000, BIT-apache-2022-37436, CLEANSTART-2026-WI35416, CLSA-2023-1675985294, DEBIAN-CVE-2022-37436, GHSA-3f78-wq4j-7vgr, UBUNTU-CVE-2022-37436, USN-5839-2

## What is CVE-2022-37436?

CVE-2022-37436 is a medium-severity vulnerability in Apache Http Server, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Prior to Apache HTTP Server 2.4.55, a malicious backend can cause the response headers to be truncated early, resulting in some headers being incorporated into the response body. If the later headers have any security purpose, they will not be interpreted by the client.

Weakness: CWE-436 (Interpretation Conflict), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2022-37436?

1 open source package ship an affected version, including apache. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache` | Bitnami | All versions | 2.4.55 |

Products: Apache Http Server.

## How do I fix CVE-2022-37436?

Upgrade apache to 2.4.55 or later.

## Is CVE-2022-37436 being exploited?

There is no known exploitation of CVE-2022-37436 in the wild and no public exploit code.

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-37436 and fix it if it is affected.

What it is: CVE-2022-37436 is a medium-severity vulnerability in Apache Http Server, published on 17 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-37436 in the wild and no public exploit code.

Affected packages and fixed versions:
- apache (Bitnami): affected all versions; fixed in 2.4.55

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-37436/ (Markdown: https://insights.sbomify.com/CVE-2022-37436/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-37436
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-37436
- OSV: https://osv.dev/vulnerability/CVE-2022-37436

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-37436/
Summaries are generated and may contain mistakes; the official description above is the record.
