# CVE-2022-37454: Buffer overflow in sponge queue functions

> An integer overflow in the Keccak SHA-3 reference implementation allows attackers to execute arbitrary code or bypass cryptographic properties.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Oct 2022
- **Updated:** 14 Oct 2026
- **Also known as:** ALPINE-CVE-2022-37454, AZL-11501, AZL-11503, BIT-libphp-2022-37454, BIT-libpython-2022-37454, BIT-php-2022-37454, BIT-php-min-2022-37454, BIT-python-2022-37454, BIT-python-min-2022-37454, CLSA-2026-1776958842, DEBIAN-CVE-2022-37454, DLA-3174-1, DLA-3175-1, DSA-5267-1, DSA-5269-1, ECHO-0e5a-4b7e-f54c, GHSA-6w4m-2xhg-2658, OESA-2022-2137, OESA-2023-1023, OESA-2023-1045, PSF-2022-11, PYSEC-2026-504, UBUNTU-CVE-2022-37454, USN-5767-3, USN-5930-1, USN-5931-1, USN-6524-1, USN-6525-1, openSUSE-SU-2024:12461-1, openSUSE-SU-2024:12476-1, openSUSE-SU-2024:12559-1, openSUSE-SU-2024:12563-1

## What is CVE-2022-37454?

CVE-2022-37454 is a critical vulnerability in Debian Debian Linux, published on 21 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Keccak XKCP SHA-3 reference implementation before fdc6fef has an integer overflow and resultant buffer overflow that allows attackers to execute arbitrary code or eliminate expected cryptographic properties. This occurs in the sponge function interface.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2022-37454?

11 open source packages ship an affected version, including pysha3, libphp and libpython. It affects 8 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pysha3` | PyPI | All versions to 1.0.2 | None |
| `pysha3` | PyPI | All versions to 1.0.2 | None |
| `pysha3` | PyPI | All versions to 1.0.2 | None |
| `libphp` | Bitnami | From 7.2.0 | 7.4.33, 8.0.25, 8.1.12 |
| `libpython` | Bitnami | From 3.6.0 | 3.7.16, 3.8.16, 3.9.16, 3.10.9 |
| `php` | Bitnami | From 7.2.0 | 7.4.33, 8.0.25, 8.1.12 |
| `php-min` | Bitnami | From 7.2.0 | 7.4.33, 8.0.25, 8.1.12 |
| `python` | Bitnami | From 3.6.0 | 3.7.16, 3.8.16, 3.9.16, 3.10.9 |
| `python-min` | Bitnami | From 3.6.0 | 3.7.16, 3.8.16, 3.9.16, 3.10.9 |
| `sha3` | RubyGems | All versions | 1.0.5 |
| `sha3` | RubyGems | All versions | 1.0.5 |
| `php7` | openSUSE:Tumbleweed | All versions | 7.4.33-1.1 |
| `python310` | openSUSE:Tumbleweed | All versions | 3.10.9-1.1 |
| `python38` | openSUSE:Tumbleweed | All versions | 3.8.15-3.1 |
| `python39` | openSUSE:Tumbleweed | All versions | 3.9.16-1.1 |

Products: Debian Debian Linux, Extended Keccak Code Package Project Extended Keccak Code Package, Fedoraproject Fedora, Php Php, Pypy Pypy, Pysha3 Project Pysha3, Python Python, Sha3 Project Sha3.

## How do I fix CVE-2022-37454?

Apply the vendor's patch.

## Is CVE-2022-37454 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-37454 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-37454 and fix it if it is affected.

What it is: CVE-2022-37454 is a critical vulnerability in Debian Debian Linux, published on 21 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-37454 exists.

Affected packages and fixed versions:
- pysha3 (PyPI): affected all versions up to 1.0.2; no fix listed
- pysha3 (PyPI): affected all versions up to 1.0.2; no fix listed
- pysha3 (PyPI): affected all versions up to 1.0.2; no fix listed
- libphp (Bitnami): affected from 7.2.0; fixed in 7.4.33, 8.0.25, 8.1.12
- libpython (Bitnami): affected from 3.6.0; fixed in 3.7.16, 3.8.16, 3.9.16, 3.10.9
- php (Bitnami): affected from 7.2.0; fixed in 7.4.33, 8.0.25, 8.1.12
- php-min (Bitnami): affected from 7.2.0; fixed in 7.4.33, 8.0.25, 8.1.12
- python (Bitnami): affected from 3.6.0; fixed in 3.7.16, 3.8.16, 3.9.16, 3.10.9
- python-min (Bitnami): affected from 3.6.0; fixed in 3.7.16, 3.8.16, 3.9.16, 3.10.9
- sha3 (RubyGems): affected all versions; fixed in 1.0.5
- sha3 (RubyGems): affected all versions; fixed in 1.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-37454/ (Markdown: https://insights.sbomify.com/CVE-2022-37454/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-37454
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-37454
- OSV: https://osv.dev/vulnerability/CVE-2022-37454

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-37454/
Summaries are generated and may contain mistakes; the official description above is the record.
