# CVE-2022-3754: Weak Password Requirements in thorsten/phpmyfaq

> Weak password requirements in phpMyFAQ allow attackers to guess credentials and take over user accounts.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2022
- **Updated:** 8 May 2025
- **Also known as:** GHSA-2rr3-rv49-p42f

## What is CVE-2022-3754?

CVE-2022-3754 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 29 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Weak Password Requirements in GitHub repository thorsten/phpmyfaq prior to 3.1.8.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2022-3754?

2 open source packages ship an affected version, including thorsten/phpmyfaq. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thorsten/phpmyfaq` | Packagist | All versions | 3.1.8 |
| `thorsten/phpmyfaq` | Packagist | All versions | 3.1.8 |

Products: Phpmyfaq Phpmyfaq.

## How do I fix CVE-2022-3754?

Upgrade thorsten/phpmyfaq to 3.1.8 or later.

## Is CVE-2022-3754 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3754 exists.

## Other vulnerabilities in Phpmyfaq Phpmyfaq

- [CVE-2023-0310](https://insights.sbomify.com/CVE-2023-0310/): Cross-site Scripting (XSS) - Stored in thorsten/phpmyfaq (critical 9.8)
- [CVE-2022-4407](https://insights.sbomify.com/CVE-2022-4407/): Cross-site Scripting (XSS) - Reflected in thorsten/phpmyfaq (critical 9.8)
- [CVE-2017-11187](https://insights.sbomify.com/CVE-2017-11187/): Security feature bypass in n/a (critical 9.8)
- [CVE-2026-76213](https://insights.sbomify.com/CVE-2026-76213/): phpMyFAQ before 4.1.7 2FA Brute-Force via Session-Scoped Throttle (critical 9.1)
- [CVE-2026-76214](https://insights.sbomify.com/CVE-2026-76214/): phpMyFAQ before 4.1.7 WebAuthn Replay Attack via Challenge (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3754 and fix it if it is affected.

What it is: CVE-2022-3754 is a high-severity vulnerability in Phpmyfaq Phpmyfaq, published on 29 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3754 exists.

Affected packages and fixed versions:
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 3.1.8
- thorsten/phpmyfaq (Packagist): affected all versions; fixed in 3.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3754/ (Markdown: https://insights.sbomify.com/CVE-2022-3754/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3754
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3754
- OSV: https://osv.dev/vulnerability/CVE-2022-3754

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3754/
Summaries are generated and may contain mistakes; the official description above is the record.
