CVE-2022-3758 Missing authorization in GitLab
An unauthorized user can read, add, or edit private snippets due to improper permission checks in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-3758?
CVE-2022-3758 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 9 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab affecting all versions starting from 15.5 before 15.7.8, all versions starting from 15.8 before 15.8.4, all versions starting from 15.9 before 15.9.2. Due to improper permissions checks an unauthorised user was able to read, add or edit a users private snippet.
Weakness: CWE-276
Which versions are affected by CVE-2022-3758?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 15.5.0 | 15.7.8, 15.8.4, 15.9.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-3758?
Upgrade gitlab to a fixed version for your release line: 15.7.8, 15.8.4 or 15.9.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-3758 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3758 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-3758, GHSA-3342-4jqh-pxw7, UBUNTU-CVE-2022-3758.