# CVE-2022-37611: tschaub gh-pages vulnerable to prototype pollution

> Prototype pollution in gh-pages allows attackers to manipulate object prototypes, potentially leading to arbitrary code execution in Node.js applications.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Oct 2022
- **Updated:** 15 May 2025
- **Also known as:** CLSA-2026-1781830595, GHSA-8mmm-9v2q-x3f9

## What is CVE-2022-37611?

CVE-2022-37611 is a critical vulnerability in n/a, published on 12 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Prototype pollution vulnerability in tschaub gh-pages 3.1.0 via the partial variable in util.js.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-37611?

2 open source packages ship an affected version, including gh-pages. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gh-pages` | npm | All versions | 5.0.0 |
| `gh-pages` | npm | All versions | 5.0.0 |

Products: Gh-Pages Project Gh-Pages.

## How do I fix CVE-2022-37611?

Upgrade gh-pages to 5.0.0 or later.

## Is CVE-2022-37611 being exploited?

There is no known exploitation of CVE-2022-37611 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-37611 and fix it if it is affected.

What it is: CVE-2022-37611 is a critical vulnerability in n/a, published on 12 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-37611 in the wild and no public exploit code.

Affected packages and fixed versions:
- gh-pages (npm): affected all versions; fixed in 5.0.0
- gh-pages (npm): affected all versions; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-37611/ (Markdown: https://insights.sbomify.com/CVE-2022-37611/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-37611
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-37611
- OSV: https://osv.dev/vulnerability/CVE-2022-37611

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-37611/
Summaries are generated and may contain mistakes; the official description above is the record.
