CVE-2022-37616 Withdrawn: Improperly Controlled Modification of Object Prototype Attributes ('Prototype Pollution') in @xmldom/xmldom and xmldom

Critical 9.8 Published Updated

Prototype pollution in xmldom allows attackers to modify object prototypes, potentially leading to unexpected behavior or security bypasses in Node.js applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-37616?

CVE-2022-37616 is a critical vulnerability in Debian Debian Linux, published on 11 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A prototype pollution vulnerability exists in the function copy in dom.js in the xmldom (published as @xmldom/xmldom) package before 0.8.3 for Node.js via the p variable. NOTE: the vendor states "we are in the process of marking this report as invalid"; however, some third parties takes the position that "A prototype injection/Prototype pollution is not just when global objects are polluted with recursive merge or deep cloning but also when a target object is polluted."

Weakness: CWE-1321

Which versions are affected by CVE-2022-37616?

8 open source packages ship an affected version, including @xmldom/xmldom and xmldom. It affects 2 products.

PackageAffectedFixed in
@xmldom/xmldom npmAll versions0.7.6
@xmldom/xmldom npmAll versions0.7.6
@xmldom/xmldom npmFrom 0.8.00.8.3
@xmldom/xmldom npmFrom 0.8.00.8.3
@xmldom/xmldom npmFrom 0.9.0-beta.10.9.0-beta.2
@xmldom/xmldom npmFrom 0.9.0-beta.10.9.0-beta.2
2 more packages
xmldom npmAll versions to 0.6.0None
xmldom npmAll versions to 0.6.0None

Products include Debian Debian Linux, Xmldom Project Xmldom.

How do I fix CVE-2022-37616?

Upgrade @xmldom/xmldom to a fixed version for your release line: 0.7.6, 0.8.3 or 0.9.0-beta.2.

Is CVE-2022-37616 being exploited?

There is no known exploitation of CVE-2022-37616 in the wild and no public exploit code.

All Debian Debian Linux vulnerabilities

Sources

Also known as AZL-38290, DEBIAN-CVE-2022-37616, DLA-3154-1, GHSA-9pgh-qqpf-7wqj, UBUNTU-CVE-2022-37616.

Is CVE-2022-37616 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free