# CVE-2022-37616: Withdrawn: Improperly Controlled Modification of Object Prototype Attributes ('Prototype Pollution') in @xmldom/xmldom and xmldom

> Prototype pollution in xmldom allows attackers to modify object prototypes, potentially leading to unexpected behavior or security bypasses in Node.js applications.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Oct 2022
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-38290, DEBIAN-CVE-2022-37616, DLA-3154-1, GHSA-9pgh-qqpf-7wqj, UBUNTU-CVE-2022-37616

## What is CVE-2022-37616?

CVE-2022-37616 is a critical vulnerability in Debian Debian Linux, published on 11 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A prototype pollution vulnerability exists in the function copy in dom.js in the xmldom (published as @xmldom/xmldom) package before 0.8.3 for Node.js via the p variable. NOTE: the vendor states "we are in the process of marking this report as invalid"; however, some third parties takes the position that "A prototype injection/Prototype pollution is not just when global objects are polluted with recursive merge or deep cloning but also when a target object is polluted."

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-37616?

8 open source packages ship an affected version, including @xmldom/xmldom and xmldom. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@xmldom/xmldom` | npm | All versions | 0.7.6 |
| `@xmldom/xmldom` | npm | All versions | 0.7.6 |
| `@xmldom/xmldom` | npm | From 0.8.0 | 0.8.3 |
| `@xmldom/xmldom` | npm | From 0.8.0 | 0.8.3 |
| `@xmldom/xmldom` | npm | From 0.9.0-beta.1 | 0.9.0-beta.2 |
| `@xmldom/xmldom` | npm | From 0.9.0-beta.1 | 0.9.0-beta.2 |
| `xmldom` | npm | All versions to 0.6.0 | None |
| `xmldom` | npm | All versions to 0.6.0 | None |

Products: Debian Debian Linux, Xmldom Project Xmldom.

## How do I fix CVE-2022-37616?

Upgrade @xmldom/xmldom to a fixed version for your release line: 0.7.6, 0.8.3 or 0.9.0-beta.2.

## Is CVE-2022-37616 being exploited?

There is no known exploitation of CVE-2022-37616 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-37616 and fix it if it is affected.

What it is: CVE-2022-37616 is a critical vulnerability in Debian Debian Linux, published on 11 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-37616 in the wild and no public exploit code.

Affected packages and fixed versions:
- @xmldom/xmldom (npm): affected all versions; fixed in 0.7.6
- @xmldom/xmldom (npm): affected all versions; fixed in 0.7.6
- @xmldom/xmldom (npm): affected from 0.8.0; fixed in 0.8.3
- @xmldom/xmldom (npm): affected from 0.8.0; fixed in 0.8.3
- @xmldom/xmldom (npm): affected from 0.9.0-beta.1; fixed in 0.9.0-beta.2
- @xmldom/xmldom (npm): affected from 0.9.0-beta.1; fixed in 0.9.0-beta.2
- xmldom (npm): affected all versions up to 0.6.0; no fix listed
- xmldom (npm): affected all versions up to 0.6.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-37616/ (Markdown: https://insights.sbomify.com/CVE-2022-37616/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-37616
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-37616
- OSV: https://osv.dev/vulnerability/CVE-2022-37616

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-37616/
Summaries are generated and may contain mistakes; the official description above is the record.
