{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-37706 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2022-37706 is a high-severity vulnerability in n/a, published on 25 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-37706 and fix it if it is affected.\n\nWhat it is: CVE-2022-37706 is a high-severity vulnerability in n/a, published on 25 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-37706 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-37706/ (Markdown: https://insights.sbomify.com/CVE-2022-37706/index.md)","id":"CVE-2022-37706","markdown":"https://insights.sbomify.com/CVE-2022-37706/index.md","name":"CVE-2022-37706","record":{"aliases":["DEBIAN-CVE-2022-37706","DLA-3115-1","DSA-5233-1","GHSA-j268-37pf-rvx9","MGASA-2022-0360","UBUNTU-CVE-2022-37706","openSUSE-SU-2022:10153-1","openSUSE-SU-2024:12365-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Enlightenment desktop environment","requires_auth":"low_privilege","summary":"Local attackers can gain root privileges due to improper handling of pathnames in the setuid enlightenment_sys binary.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"enlightenment","vendor":"enlightenment"}],"cvss":{"score":7.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"enlightenment_sys in Enlightenment before 0.25.4 allows local users to gain privileges because it is setuid root, and the system library function mishandles pathnames that begin with a /dev/.. substring.","ecosystems":["SUSE:Package Hub 15 SP4","openSUSE:Leap 15.4"],"exploits":{"exploitdb":1,"first_seen":"2022-09-12","github_poc":8,"max_poc_stars":323,"metasploit":1,"nuclei":0,"refs":[{"date":"2022-09-12T19:22:44Z","kind":"github_poc","ref":"https://github.com/MaherAzzouzi/CVE-2022-37706-LPE-exploit","stars":323,"title":"A reliable exploit + write-up to elevate privileges to root. (Tested on Ubuntu 22.04)"},{"date":"2022-09-18T08:04:08Z","kind":"github_poc","ref":"https://github.com/ECU-10525611-Xander/CVE-2022-37706","stars":2,"title":"All Credit to MaherAzzouzi (https://github.com/MaherAzzouzi/CVE-2022-37706-LPE-exploit). This is a copy of the exploit for CTFs"},{"date":"2024-09-10T11:14:10Z","kind":"github_poc","ref":"https://github.com/KaoXx/CVE-2022-37706","stars":1,"title":null},{"date":"2024-12-10T12:52:29Z","kind":"github_poc","ref":"https://github.com/d3ndr1t30x/CVE-2022-37706","stars":1,"title":"Privilege escaltion exploit script for Boardlight machine on HackTheBox. I had access as the Larissa user and ran this script from the /tmp directory; script has been adjusted accordingly."},{"date":"2022-09-13","kind":"metasploit","ref":"exploit/linux/local/ubuntu_enlightenment_mount_priv_esc","stars":null,"title":"Ubuntu Enlightenment Mount Priv Esc"},{"date":"2023-04-01","kind":"exploitdb","ref":"51180","stars":null,"title":"Enlightenment v0.25.3 - Privilege escalation"},{"date":"2024-06-03T01:17:04Z","kind":"github_poc","ref":"https://github.com/junnythemarksman/CVE-2022-37706","stars":0,"title":"Exploit created by nu11secur1ty (https://github.com/nu11secur1ty/CVE-mitre/tree/main/CVE-2022-37706)"},{"date":"2024-07-19T23:12:40Z","kind":"github_poc","ref":"https://github.com/TACTICAL-HACK/CVE-2022-37706-SUID","stars":0,"title":"CVE-2022-37706-Enlightenment v0.25.3 - Privilege escalation"}],"tier":"weaponised"},"has_fix":true,"headline":"Privilege escalation in n/a","id":"CVE-2022-37706","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2022-37708"},"packages":[{"ecosystem":"SUSE:Package Hub 15 SP4","fixed":["0.25.4-bp154.4.3.1"],"introduced":["0"],"last_affected":[],"package":"enlightenment","purl":"pkg:rpm/suse/enlightenment\u0026distro=SUSE%20Package%20Hub%2015%20SP4","source":"openSUSE-SU-2022:10153-1"},{"ecosystem":"openSUSE:Leap 15.4","fixed":["0.25.4-bp154.4.3.1"],"introduced":["0"],"last_affected":[],"package":"enlightenment","purl":"pkg:rpm/opensuse/enlightenment\u0026distro=openSUSE%20Leap%2015.4","source":"openSUSE-SU-2022:10153-1"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2022-37705"},"products":["n/a"],"published":"2022-12-25","related":[{"cvss_score":7.8,"headline":"Privilege escalation in n/a","id":"CVE-2014-1845","kev_date_added":null,"published":"2018-04-27"},{"cvss_score":7.8,"headline":"Privilege escalation in n/a","id":"CVE-2014-1846","kev_date_added":null,"published":"2018-04-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"BSD-3-Clause","name":"Metasploit"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-14","vendors":["n/a"]},"summary":"Local attackers can gain root privileges due to improper handling of pathnames in the setuid enlightenment_sys binary.","url":"https://insights.sbomify.com/CVE-2022-37706/"}