CVE-2022-37734 graphql-java vulnerable to Denial of Service via GraphQL query that consumes CPU resources
An attacker can cause a denial of service by sending a malicious GraphQL query that consumes excessive CPU resources in graphql-java.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-37734?
CVE-2022-37734 is a high-severity denial of service vulnerability in n/a, published on 12 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
graphql-java before19.0 is vulnerable to Denial of Service. An attacker can send a malicious GraphQL query that consumes CPU resources. The fixed versions are 19.0 and later, 18.3, and 17.4, and 0.0.0-2022-07-26T05-45-04-226aabd9.
Which versions are affected by CVE-2022-37734?
4 open source packages ship an affected version, including com.graphql-java:graphql-java. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.graphql-java:graphql-java Maven | All versions | 17.4 |
com.graphql-java:graphql-java Maven | All versions | 17.4 |
com.graphql-java:graphql-java Maven | From 18.0 | 18.3 |
com.graphql-java:graphql-java Maven | From 18.0 | 18.3 |
Products include Graphql-Java Project Graphql-Java.
How do I fix CVE-2022-37734?
Upgrade com.graphql-java:graphql-java to a fixed version for your release line: 17.4 or 18.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-37734 being exploited?
There is no known exploitation of CVE-2022-37734 in the wild and no public exploit code.
Sources
Also known as GHSA-v62j-cxhh-fq22, ROOT-APP-MAVEN-CVE-2022-37734.