# CVE-2022-37734: graphql-java vulnerable to Denial of Service via GraphQL query that consumes CPU resources

> An attacker can cause a denial of service by sending a malicious GraphQL query that consumes excessive CPU resources in graphql-java.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Sep 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-v62j-cxhh-fq22, ROOT-APP-MAVEN-CVE-2022-37734

## What is CVE-2022-37734?

CVE-2022-37734 is a high-severity denial of service vulnerability in n/a, published on 12 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

graphql-java before19.0 is vulnerable to Denial of Service. An attacker can send a malicious GraphQL query that consumes CPU resources. The fixed versions are 19.0 and later, 18.3, and 17.4, and 0.0.0-2022-07-26T05-45-04-226aabd9.

## Which versions are affected by CVE-2022-37734?

4 open source packages ship an affected version, including com.graphql-java:graphql-java. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.graphql-java:graphql-java` | Maven | All versions | 17.4 |
| `com.graphql-java:graphql-java` | Maven | All versions | 17.4 |
| `com.graphql-java:graphql-java` | Maven | From 18.0 | 18.3 |
| `com.graphql-java:graphql-java` | Maven | From 18.0 | 18.3 |

Products: Graphql-Java Project Graphql-Java.

## How do I fix CVE-2022-37734?

Upgrade com.graphql-java:graphql-java to a fixed version for your release line: 17.4 or 18.3.

## Is CVE-2022-37734 being exploited?

There is no known exploitation of CVE-2022-37734 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-37734 and fix it if it is affected.

What it is: CVE-2022-37734 is a high-severity denial of service vulnerability in n/a, published on 12 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-37734 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.graphql-java:graphql-java (Maven): affected all versions; fixed in 17.4
- com.graphql-java:graphql-java (Maven): affected all versions; fixed in 17.4
- com.graphql-java:graphql-java (Maven): affected from 18.0; fixed in 18.3
- com.graphql-java:graphql-java (Maven): affected from 18.0; fixed in 18.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-37734/ (Markdown: https://insights.sbomify.com/CVE-2022-37734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-37734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-37734
- OSV: https://osv.dev/vulnerability/CVE-2022-37734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-37734/
Summaries are generated and may contain mistakes; the official description above is the record.
