{"answers":{"affected":"2 open source packages ship an affected version, including node-red-dashboard. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3783 exists.","fix":"Upgrade node-red-dashboard to 3.2.0 or later.","what":"CVE-2022-3783 is a low-severity cross-site scripting vulnerability in unspecified node-red-dashboard, published on 31 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-3783 and fix it if it is affected.\n\nWhat it is: CVE-2022-3783 is a low-severity cross-site scripting vulnerability in unspecified node-red-dashboard, published on 31 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3783 exists.\n\nAffected packages and fixed versions:\n- node-red-dashboard (npm): affected all versions; fixed in 3.2.0\n- node-red-dashboard (npm): affected all versions; fixed in 3.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-3783/ (Markdown: https://insights.sbomify.com/CVE-2022-3783/index.md)","id":"CVE-2022-3783","markdown":"https://insights.sbomify.com/CVE-2022-3783/index.md","name":"CVE-2022-3783","record":{"aliases":["GHSA-vrv9-3x3w-ffxw"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Node-RED dashboard plugin","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via cross-site scripting in the ui_text format handler of the node-red-dashboard plugin.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"node-red-dashboard","vendor":"nodered"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-707","name":"Improper Neutralization"}],"description":"A vulnerability, which was classified as problematic, has been found in node-red-dashboard. This issue affects some unknown processing of the file components/ui-component/ui-component-ctrl.js of the component ui_text Format Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The name of the patch is 9305d1a82f19b235dfad24a7d1dd4ed244db7743. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-212555.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"node-red-dashboard ui_text Format ui-component-ctrl.js cross site scripting","id":"CVE-2022-3783","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Axiomatic Bento4 mp4hls Ap4Mp4AudioInfo.cpp ReadBits heap-based overflow","id":"CVE-2022-3784"},"packages":[{"ecosystem":"npm","fixed":["3.2.0"],"introduced":["0"],"last_affected":[],"package":"node-red-dashboard","purl":null,"source":"GHSA-vrv9-3x3w-ffxw"},{"ecosystem":"npm","fixed":["3.2.0"],"introduced":["0"],"last_affected":[],"package":"node-red-dashboard","purl":"pkg:npm/node-red-dashboard","source":"GHSA-vrv9-3x3w-ffxw"}],"prev":{"headline":"Keycloak vulnerable to path traversal via double URL encoding","id":"CVE-2022-3782"},"products":["node-red-dashboard"],"published":"2022-10-31","related":[{"cvss_score":7.5,"headline":"Path traversal in Node-RED-Dashboard","id":"CVE-2021-3223","kev_date_added":null,"published":"2021-01-26"},{"cvss_score":5.4,"headline":"Cross-site Scripting in node-red-dashboard","id":"CVE-2019-10756","kev_date_added":null,"published":"2019-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["unspecified"]},"summary":"Remote attackers can execute arbitrary scripts via cross-site scripting in the ui_text format handler of the node-red-dashboard plugin.","url":"https://insights.sbomify.com/CVE-2022-3783/"}