# CVE-2022-3783: node-red-dashboard ui_text Format ui-component-ctrl.js cross site scripting

> Remote attackers can execute arbitrary scripts via cross-site scripting in the ui_text format handler of the node-red-dashboard plugin.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Oct 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-vrv9-3x3w-ffxw

## What is CVE-2022-3783?

CVE-2022-3783 is a low-severity cross-site scripting vulnerability in unspecified node-red-dashboard, published on 31 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, has been found in node-red-dashboard. This issue affects some unknown processing of the file components/ui-component/ui-component-ctrl.js of the component ui_text Format Handler. The manipulation leads to cross site scripting. The attack may be initiated remotely. The name of the patch is 9305d1a82f19b235dfad24a7d1dd4ed244db7743. It is recommended to apply a patch to fix this issue. The associated identifier of this vulnerability is VDB-212555.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2022-3783?

2 open source packages ship an affected version, including node-red-dashboard. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `node-red-dashboard` | npm | All versions | 3.2.0 |
| `node-red-dashboard` | npm | All versions | 3.2.0 |

Products: Nodered Node-Red-Dashboard.

## How do I fix CVE-2022-3783?

Upgrade node-red-dashboard to 3.2.0 or later.

## Is CVE-2022-3783 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3783 exists.

## Other vulnerabilities in unspecified node-red-dashboard

- [CVE-2021-3223](https://insights.sbomify.com/CVE-2021-3223/): Path traversal in Node-RED-Dashboard (high 7.5)
- [CVE-2019-10756](https://insights.sbomify.com/CVE-2019-10756/): Cross-site Scripting in node-red-dashboard (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3783 and fix it if it is affected.

What it is: CVE-2022-3783 is a low-severity cross-site scripting vulnerability in unspecified node-red-dashboard, published on 31 Oct 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3783 exists.

Affected packages and fixed versions:
- node-red-dashboard (npm): affected all versions; fixed in 3.2.0
- node-red-dashboard (npm): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3783/ (Markdown: https://insights.sbomify.com/CVE-2022-3783/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3783
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3783
- OSV: https://osv.dev/vulnerability/CVE-2022-3783

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3783/
Summaries are generated and may contain mistakes; the official description above is the record.
