# CVE-2022-3786: X.509 Email Address Variable Length Buffer Overflow

> A buffer overflow in OpenSSL's X.509 name constraint checking allows attackers to cause a denial of service via malicious certificates.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Nov 2022
- **Updated:** 14 Apr 2026
- **Also known as:** ALPINE-CVE-2022-3786, BIT-node-2022-3786, BIT-node-min-2022-3786, CLEANSTART-2026-NT43765, CLEANSTART-2026-PY31996, DEBIAN-CVE-2022-3786, GHSA-h8jm-2x53-xhp5, RUSTSEC-2022-0065, UBUNTU-CVE-2022-3786

## What is CVE-2022-3786?

CVE-2022-3786 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 1 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A buffer overrun can be triggered in X.509 certificate verification, specifically in name constraint checking. Note that this occurs after certificate chain signature verification and requires either a CA to have signed a malicious certificate or for an application to continue certificate verification despite failure to construct a path to a trusted issuer. An attacker can craft a malicious email address in a certificate to overflow an arbitrary number of bytes containing the `.' character (decimal 46) on the stack. This buffer overflow could result in a crash (causing a denial of service). In a TLS client, this can be triggered by connecting to a malicious server. In a TLS server, this can be triggered if the server requests client authentication and a malicious client connects.

Weakness: CWE-120 (Buffer Copy without Checking Size of Input)

## Which versions are affected by CVE-2022-3786?

5 open source packages ship an affected version, including openssl-src, node and node-min. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.11 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.11 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.11 |
| `node` | Bitnami | From 18.0.0 | 18.11.0, 18.12.1, 19.0.1 |
| `node-min` | Bitnami | From 18.0.0 | 18.11.0, 18.12.1, 19.0.1 |

Products: Fedoraproject Fedora, Nodejs Node.js, Openssl Openssl.

## How do I fix CVE-2022-3786?

Upgrade openssl-src to 300.0.11 or later.

## Is CVE-2022-3786 being exploited?

There is no known exploitation of CVE-2022-3786 in the wild and no public exploit code.

Public exploit code:

- Finding CVE-2022-3786 (openssl) with Mayhem (github_poc): https://github.com/WhatTheFuzz/openssl-fuzz

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3786 and fix it if it is affected.

What it is: CVE-2022-3786 is a high-severity memory corruption vulnerability in Fedoraproject Fedora, published on 1 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-3786 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.11
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.11
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.11
- node (Bitnami): affected from 18.0.0; fixed in 18.11.0, 18.12.1, 19.0.1
- node-min (Bitnami): affected from 18.0.0; fixed in 18.11.0, 18.12.1, 19.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3786/ (Markdown: https://insights.sbomify.com/CVE-2022-3786/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3786
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3786
- OSV: https://osv.dev/vulnerability/CVE-2022-3786

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3786/
Summaries are generated and may contain mistakes; the official description above is the record.
