{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.ivy:ivy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-37865 in the wild and no public exploit code.","fix":"Upgrade org.apache.ivy:ivy to 2.5.1 or later.","what":"CVE-2022-37865 is a critical path traversal vulnerability in Apache Ivy, published on 7 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-37865 and fix it if it is affected.\n\nWhat it is: CVE-2022-37865 is a critical path traversal vulnerability in Apache Ivy, published on 7 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-37865 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.ivy:ivy (Maven): affected from 2.4.0; fixed in 2.5.1\n- org.apache.ivy:ivy (Maven): affected from 2.4.0; fixed in 2.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-37865/ (Markdown: https://insights.sbomify.com/CVE-2022-37865/index.md)","id":"CVE-2022-37865","markdown":"https://insights.sbomify.com/CVE-2022-37865/index.md","name":"CVE-2022-37865","record":{"aliases":["GHSA-94rr-4jr5-9h2p"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Ivy library","requires_auth":"none","summary":"Attackers can overwrite arbitrary files on the system via malicious archives in Apache Ivy when using optional zip packaging features.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"ivy","vendor":"apache"}],"cvss":{"score":9.1,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"With Apache Ivy 2.4.0 an optional packaging attribute has been introduced that allows artifacts to be unpacked on the fly if they used pack200 or zip packaging. For artifacts using the \"zip\", \"jar\" or \"war\" packaging Ivy prior to 2.5.1 doesn't verify the target path when extracting the archive. An archive containing absolute paths or paths that try to traverse \"upwards\" using \"..\" sequences can then write files to any location on the local fie system that the user executing Ivy has write access to. Ivy users of version 2.4.0 to 2.5.0 should upgrade to Ivy 2.5.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Ivy allows creating/overwriting any file on the system","id":"CVE-2022-37865","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Apache Ivy allows path traversal in the presence of a malicious repository","id":"CVE-2022-37866"},"packages":[{"ecosystem":"Maven","fixed":["2.5.1"],"introduced":["2.4.0"],"last_affected":[],"package":"org.apache.ivy:ivy","purl":null,"source":"GHSA-94rr-4jr5-9h2p"},{"ecosystem":"Maven","fixed":["2.5.1"],"introduced":["2.4.0"],"last_affected":[],"package":"org.apache.ivy:ivy","purl":"pkg:maven/org.apache.ivy/ivy","source":"GHSA-94rr-4jr5-9h2p"}],"prev":{"headline":"Memory corruption in Solid Edge","id":"CVE-2022-37864"},"products":["Apache Ivy"],"published":"2022-11-07","related":[{"cvss_score":8.2,"headline":"Apache Ivy: XML External Entity vulnerability in Apache Ivy","id":"CVE-2022-46751","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":7.5,"headline":"Apache Ivy allows path traversal in the presence of a malicious repository","id":"CVE-2022-37866","kev_date_added":null,"published":"2022-11-07"},{"cvss_score":5.4,"headline":"Apache Ivy: PackagerResolver path traversal vulnerability","id":"CVE-2026-26032","kev_date_added":null,"published":"2026-07-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-02","vendors":["Apache Software Foundation"]},"summary":"Attackers can overwrite arbitrary files on the system via malicious archives in Apache Ivy when using optional zip packaging features.","url":"https://insights.sbomify.com/CVE-2022-37865/"}