{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.ivy:ivy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-37866 in the wild and no public exploit code.","fix":"Upgrade org.apache.ivy:ivy to 2.5.1 or later.","what":"CVE-2022-37866 is a high-severity path traversal vulnerability in Apache Ivy, published on 7 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-37866 and fix it if it is affected.\n\nWhat it is: CVE-2022-37866 is a high-severity path traversal vulnerability in Apache Ivy, published on 7 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-37866 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.ivy:ivy (Maven): affected from 2.0.0; fixed in 2.5.1\n- org.apache.ivy:ivy (Maven): affected from 2.0.0; fixed in 2.5.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-37866/ (Markdown: https://insights.sbomify.com/CVE-2022-37866/index.md)","id":"CVE-2022-37866","markdown":"https://insights.sbomify.com/CVE-2022-37866/index.md","name":"CVE-2022-37866","record":{"aliases":["GHSA-wv7w-rj2x-556x"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Ivy library","requires_auth":"none","summary":"Attackers can write files outside the cache or overwrite artifacts via malicious repository coordinates, requiring repository collaboration.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"ivy","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"When Apache Ivy downloads artifacts from a repository it stores them in the local file system based on a user-supplied \"pattern\" that may include placeholders for artifacts coordinates like the organisation, module or version. If said coordinates contain \"../\" sequences - which are valid characters for Ivy coordinates in general - it is possible the artifacts are stored outside of Ivy's local cache or repository or can overwrite different artifacts inside of the local cache. In order to exploit this vulnerability an attacker needs collaboration by the remote repository as Ivy will issue http requests containing \"..\" sequences and a \"normal\" repository will not interpret them as part of the artifact coordinates. Users of Apache Ivy 2.0.0 to 2.5.1 should upgrade to Ivy 2.5.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Ivy allows path traversal in the presence of a malicious repository","id":"CVE-2022-37866","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Privilege escalation in Aruba ClearPass Policy Manager","id":"CVE-2022-37877"},"packages":[{"ecosystem":"Maven","fixed":["2.5.1"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.ivy:ivy","purl":null,"source":"GHSA-wv7w-rj2x-556x"},{"ecosystem":"Maven","fixed":["2.5.1"],"introduced":["2.0.0"],"last_affected":[],"package":"org.apache.ivy:ivy","purl":"pkg:maven/org.apache.ivy/ivy","source":"GHSA-wv7w-rj2x-556x"}],"prev":{"headline":"Apache Ivy allows creating/overwriting any file on the system","id":"CVE-2022-37865"},"products":["Apache Ivy"],"published":"2022-11-07","related":[{"cvss_score":9.1,"headline":"Apache Ivy allows creating/overwriting any file on the system","id":"CVE-2022-37865","kev_date_added":null,"published":"2022-11-07"},{"cvss_score":8.2,"headline":"Apache Ivy: XML External Entity vulnerability in Apache Ivy","id":"CVE-2022-46751","kev_date_added":null,"published":"2023-08-21"},{"cvss_score":5.4,"headline":"Apache Ivy: PackagerResolver path traversal vulnerability","id":"CVE-2026-26032","kev_date_added":null,"published":"2026-07-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-01","vendors":["Apache Software Foundation"]},"summary":"Attackers can write files outside the cache or overwrite artifacts via malicious repository coordinates, requiring repository collaboration.","url":"https://insights.sbomify.com/CVE-2022-37866/"}