# CVE-2022-37866: Apache Ivy allows path traversal in the presence of a malicious repository

> Attackers can write files outside the cache or overwrite artifacts via malicious repository coordinates, requiring repository collaboration.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Nov 2022
- **Updated:** 1 May 2025
- **Also known as:** GHSA-wv7w-rj2x-556x

## What is CVE-2022-37866?

CVE-2022-37866 is a high-severity path traversal vulnerability in Apache Ivy, published on 7 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When Apache Ivy downloads artifacts from a repository it stores them in the local file system based on a user-supplied "pattern" that may include placeholders for artifacts coordinates like the organisation, module or version. If said coordinates contain "../" sequences - which are valid characters for Ivy coordinates in general - it is possible the artifacts are stored outside of Ivy's local cache or repository or can overwrite different artifacts inside of the local cache. In order to exploit this vulnerability an attacker needs collaboration by the remote repository as Ivy will issue http requests containing ".." sequences and a "normal" repository will not interpret them as part of the artifact coordinates. Users of Apache Ivy 2.0.0 to 2.5.1 should upgrade to Ivy 2.5.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-37866?

2 open source packages ship an affected version, including org.apache.ivy:ivy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.ivy:ivy` | Maven | From 2.0.0 | 2.5.1 |
| `org.apache.ivy:ivy` | Maven | From 2.0.0 | 2.5.1 |

Products: Apache Ivy.

## How do I fix CVE-2022-37866?

Upgrade org.apache.ivy:ivy to 2.5.1 or later.

## Is CVE-2022-37866 being exploited?

There is no known exploitation of CVE-2022-37866 in the wild and no public exploit code.

## Other vulnerabilities in Apache Ivy

- [CVE-2022-37865](https://insights.sbomify.com/CVE-2022-37865/): Apache Ivy allows creating/overwriting any file on the system (critical 9.1)
- [CVE-2022-46751](https://insights.sbomify.com/CVE-2022-46751/): Apache Ivy: XML External Entity vulnerability in Apache Ivy (high 8.2)
- [CVE-2026-26032](https://insights.sbomify.com/CVE-2026-26032/): Apache Ivy: PackagerResolver path traversal vulnerability (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-37866 and fix it if it is affected.

What it is: CVE-2022-37866 is a high-severity path traversal vulnerability in Apache Ivy, published on 7 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-37866 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.ivy:ivy (Maven): affected from 2.0.0; fixed in 2.5.1
- org.apache.ivy:ivy (Maven): affected from 2.0.0; fixed in 2.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-37866/ (Markdown: https://insights.sbomify.com/CVE-2022-37866/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-37866
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-37866
- OSV: https://osv.dev/vulnerability/CVE-2022-37866

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-37866/
Summaries are generated and may contain mistakes; the official description above is the record.
