# CVE-2022-37915: Command injection in Aruba EdgeConnect Enterprise Orchestrator (on-premises)

> Unauthenticated remote attackers can execute arbitrary commands on Aruba EdgeConnect Enterprise Orchestrator, leading to complete system compromise.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Oct 2022
- **Updated:** 7 May 2025
- **Also known as:** GHSA-f4hw-g4gh-mmch

## What is CVE-2022-37915?

CVE-2022-37915 is a critical command injection vulnerability in Aruba EdgeConnect Enterprise Orchestrator (on-premises), published on 28 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in the web-based management interface of Aruba EdgeConnect Enterprise Orchestrator could allow an unauthenticated remote attacker to run arbitrary commands on the underlying host. Successful exploitation of this vulnerability could allow an attacker to execute arbitrary commands on the underlying operating system leading to a complete system compromise of Aruba EdgeConnect Enterprise Orchestration with versions 9.1.x branch only, Any 9.1.x Orchestrator instantiated as a new machine with a release prior to 9.1.3.40197, Orchestrators upgraded to 9.1.x were not affected.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-37915?

It affects 1 product.


Products: Arubanetworks Aruba Edgeconnect Enterprise Orchestrator.

## How do I fix CVE-2022-37915?

No fix has been published for CVE-2022-37915 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-37915 being exploited?

There is no known exploitation of CVE-2022-37915 in the wild and no public exploit code.

## Other vulnerabilities in Aruba EdgeConnect Enterprise Orchestrator (on-premises)

- [CVE-2022-37913](https://insights.sbomify.com/CVE-2022-37913/): Auth bypass in Aruba EdgeConnect Enterprise Orchestrator (on-premises), Aruba EdgeConnect Enterprise Orchestrator-as-a-Service, Aruba EdgeConnect Enterprise Orchestrator-SP and Aruba EdgeConnect Enterprise Orchestrator Global Enterprise Tenant Orchestrators (critical 9.8)
- [CVE-2022-37914](https://insights.sbomify.com/CVE-2022-37914/): Auth bypass in Aruba EdgeConnect Enterprise Orchestrator (on-premises), Aruba EdgeConnect Enterprise Orchestrator-as-a-Service, Aruba EdgeConnect Enterprise Orchestrator-SP and Aruba EdgeConnect Enterprise Orchestrator Global Enterprise Tenant Orchestrators (critical 9.8)
- [CVE-2022-43519](https://insights.sbomify.com/CVE-2022-43519/): SQL injection in Aruba EdgeConnect Enterprise Orchestration Software (high 8.8)
- [CVE-2022-43520](https://insights.sbomify.com/CVE-2022-43520/): SQL injection in Aruba EdgeConnect Enterprise Orchestration Software (high 8.8)
- [CVE-2022-43521](https://insights.sbomify.com/CVE-2022-43521/): SQL injection in Aruba EdgeConnect Enterprise Orchestration Software (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-37915 and fix it if it is affected.

What it is: CVE-2022-37915 is a critical command injection vulnerability in Aruba EdgeConnect Enterprise Orchestrator (on-premises), published on 28 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-37915 in the wild and no public exploit code.

Affected product: Aruba EdgeConnect Enterprise Orchestrator (on-premises). No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-37915/ (Markdown: https://insights.sbomify.com/CVE-2022-37915/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-37915
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-37915
- OSV: https://osv.dev/vulnerability/CVE-2022-37915

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-37915/
Summaries are generated and may contain mistakes; the official description above is the record.
