CVE-2022-3793 Missing authorization in GitLab
Attackers can read sensitive CI/CD variables from configuration files they lack access to in GitLab.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-3793?
CVE-2022-3793 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 9 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An improper authorization issue in GitLab CE/EE affecting all versions from 14.4 prior to 15.3.5, 15.4 prior to 15.4.4, and 15.5 prior to 15.5.2 allows an attacker to read variables set directly in a GitLab CI/CD configuration file they don't have access to.
Which versions are affected by CVE-2022-3793?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 12.6.0 | 15.3.5, 15.4.4, 15.5.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2022-3793?
Upgrade gitlab to a fixed version for your release line: 15.3.5, 15.4.4 or 15.5.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-3793 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3793 exists.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2022-3793, GHSA-j48w-jfc5-3885, UBUNTU-CVE-2022-3793.