# CVE-2022-38060: OpenStack Kolla sudo privilege escalation vulnerability

> A misconfiguration in OpenStack Kolla containers allows attackers to escalate privileges via sudo.

- **Severity:** High 8.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Dec 2022
- **Updated:** 7 May 2025
- **Also known as:** GHSA-rvxr-pf5f-j2qj, PYSEC-2026-838, RHSA-2024:0191, RHSA-2024:0216

## What is CVE-2022-38060?

CVE-2022-38060 is a high-severity vulnerability in OpenStack, published on 21 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A privilege escalation vulnerability exists in the sudo functionality of OpenStack Kolla git master 05194e7618. A misconfiguration in /etc/sudoers within a container can lead to increased privileges.

Weakness: CWE-426 (Untrusted Search Path), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2022-38060?

3 open source packages ship an affected version, including kolla. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kolla` | PyPI | All versions | 15.0.0.0rc1 |
| `kolla` | PyPI | All versions | 15.0.0.0rc1 |
| `kolla` | PyPI | All versions | 15.0.0.0rc1 |
| `openstack-tripleo-common` | Red Hat:openstack:17.1::el8 | All versions | 0:15.4.1-17.1.20230927003755.el8ost |
| `openstack-tripleo-common-container-base` | Red Hat:openstack:17.1::el8 | All versions | 0:15.4.1-17.1.20230927003755.el8ost |
| `openstack-tripleo-common-containers` | Red Hat:openstack:17.1::el8 | All versions | 0:15.4.1-17.1.20230927003755.el8ost |
| `python3-tripleo-common` | Red Hat:openstack:17.1::el8 | All versions | 0:15.4.1-17.1.20230927003755.el8ost |
| `openstack-tripleo-common` | Red Hat:openstack:17.1::el9 | All versions | 0:15.4.1-17.1.20230927010819.el9ost |
| `openstack-tripleo-common-container-base` | Red Hat:openstack:17.1::el9 | All versions | 0:15.4.1-17.1.20230927010819.el9ost |
| `openstack-tripleo-common-containers` | Red Hat:openstack:17.1::el9 | All versions | 0:15.4.1-17.1.20230927010819.el9ost |
| `openstack-tripleo-common-devtools` | Red Hat:openstack:17.1::el9 | All versions | 0:15.4.1-17.1.20230927010819.el9ost |
| `python3-tripleo-common` | Red Hat:openstack:17.1::el9 | All versions | 0:15.4.1-17.1.20230927010819.el9ost |

Products: Openstack Kolla.

## How do I fix CVE-2022-38060?

Upgrade kolla to 15.0.0.0rc1 or later.

## Is CVE-2022-38060 being exploited?

There is no known exploitation of CVE-2022-38060 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-38060 and fix it if it is affected.

What it is: CVE-2022-38060 is a high-severity vulnerability in OpenStack, published on 21 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-38060 in the wild and no public exploit code.

Affected packages and fixed versions:
- kolla (PyPI): affected all versions; fixed in 15.0.0.0rc1
- kolla (PyPI): affected all versions; fixed in 15.0.0.0rc1
- kolla (PyPI): affected all versions; fixed in 15.0.0.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-38060/ (Markdown: https://insights.sbomify.com/CVE-2022-38060/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-38060
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-38060
- OSV: https://osv.dev/vulnerability/CVE-2022-38060

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-38060/
Summaries are generated and may contain mistakes; the official description above is the record.
