# CVE-2022-38072: ADMesh improper array index validation

> A heap buffer overflow in ADMesh and libslic3r allows attackers to execute arbitrary code or cause denial of service via a malicious STL file.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Apr 2023
- **Updated:** 11 Feb 2025
- **Also known as:** DEBIAN-CVE-2022-38072, GHSA-v5hv-4pw3-q6h9, UBUNTU-CVE-2022-38072

## What is CVE-2022-38072?

CVE-2022-38072 is a medium-severity memory corruption vulnerability in ADMesh, published on 3 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An improper array index validation vulnerability exists in the stl_fix_normal_directions functionality of ADMesh Master Commit 767a105 and v0.98.4. A specially-crafted stl file can lead to a heap buffer overflow. An attacker can provide a malicious file to trigger this vulnerability.

Weakness: CWE-129 (Improper Validation of Array Index), CWE-118 (Incorrect Access of Indexable Resource)

## Which versions are affected by CVE-2022-38072?

2 open source packages ship an affected version, including admesh. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `admesh` | PyPI | All versions | 0.98.5 |
| `admesh` | PyPI | All versions | 0.98.5 |

Products: Admesh Project Admesh, Slic3r Libslic3r.

## How do I fix CVE-2022-38072?

Upgrade admesh to 0.98.5 or later.

## Is CVE-2022-38072 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-38072 exists.

## Other vulnerabilities in ADMesh

- [CVE-2018-25033](https://insights.sbomify.com/CVE-2018-25033/): Out-of-bounds read in admesh (high 8.1)
- [CVE-2026-2653](https://insights.sbomify.com/CVE-2026-2653/): admesh normals.c stl_check_normal_vector heap-based overflow (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-38072 and fix it if it is affected.

What it is: CVE-2022-38072 is a medium-severity memory corruption vulnerability in ADMesh, published on 3 Apr 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-38072 exists.

Affected packages and fixed versions:
- admesh (PyPI): affected all versions; fixed in 0.98.5
- admesh (PyPI): affected all versions; fixed in 0.98.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-38072/ (Markdown: https://insights.sbomify.com/CVE-2022-38072/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-38072
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-38072
- OSV: https://osv.dev/vulnerability/CVE-2022-38072

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-38072/
Summaries are generated and may contain mistakes; the official description above is the record.
