CVE-2022-38073 WordPress Awesome Support plugin <= 6.0.7 - Multiple Authenticated Persistent XSS (Additional Interested Parties)

Medium 5.4 Published Updated

Authenticated attackers can inject persistent scripts via the Additional Interested Parties feature in the Awesome Support WordPress plugin.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-38073?

CVE-2022-38073 is a medium-severity cross-site scripting vulnerability in Awesome Support (WordPress plugin), published on 21 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7 at WordPress.

Weakness: CWE-79

Which versions are affected by CVE-2022-38073?

2 open source packages ship an affected version, including awesome-support/awesome-support. It affects 1 product.

PackageAffectedFixed in
awesome-support/awesome-support PackagistAll versions6.0.8
awesome-support/awesome-support PackagistAll versions6.0.8

Products include Getawesomesupport Awesome Support.

How do I fix CVE-2022-38073?

Upgrade awesome-support/awesome-support to 6.0.8 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-38073 being exploited?

There is no known exploitation of CVE-2022-38073 in the wild and no public exploit code.

Sources

Also known as GHSA-qrqm-574x-q7f2.

Is CVE-2022-38073 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free