# CVE-2022-38073: WordPress Awesome Support plugin <= 6.0.7 - Multiple Authenticated Persistent XSS (Additional Interested Parties)

> Authenticated attackers can inject persistent scripts via the Additional Interested Parties feature in the Awesome Support WordPress plugin.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Sep 2022
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-qrqm-574x-q7f2

## What is CVE-2022-38073?

CVE-2022-38073 is a medium-severity cross-site scripting vulnerability in Awesome Support (WordPress plugin), published on 21 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Multiple Authenticated (custom specific plugin role) Persistent Cross-Site Scripting (XSS) vulnerability in Awesome Support plugin <= 6.0.7 at WordPress.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-38073?

2 open source packages ship an affected version, including awesome-support/awesome-support. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `awesome-support/awesome-support` | Packagist | All versions | 6.0.8 |
| `awesome-support/awesome-support` | Packagist | All versions | 6.0.8 |

Products: Getawesomesupport Awesome Support.

## How do I fix CVE-2022-38073?

Upgrade awesome-support/awesome-support to 6.0.8 or later.

## Is CVE-2022-38073 being exploited?

There is no known exploitation of CVE-2022-38073 in the wild and no public exploit code.

## Other vulnerabilities in Awesome Support (WordPress plugin)

- [CVE-2024-0594](https://insights.sbomify.com/CVE-2024-0594/): Awesome Support – WordPress HelpDesk & Support Plugin <= 6.1.7 - Authenticated (Subscriber+) SQL Injection (high 8.8)
- [CVE-2023-5355](https://insights.sbomify.com/CVE-2023-5355/): Awesome Support < 6.1.5 - Submitter+ Arbitrary File Deletion (high 8.1)
- [CVE-2015-9318](https://insights.sbomify.com/CVE-2015-9318/): Cross-site scripting in n/a (high 7.5)
- [CVE-2023-49857](https://insights.sbomify.com/CVE-2023-49857/): WordPress Awesome Support plugin <= 6.1.7 - Broken Access Control vulnerability (medium 6.5)
- [CVE-2022-3511](https://insights.sbomify.com/CVE-2022-3511/): Awesome Support < 6.1.2 - Subscriber+ Arbitrary Exported Tickets Download (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-38073 and fix it if it is affected.

What it is: CVE-2022-38073 is a medium-severity cross-site scripting vulnerability in Awesome Support (WordPress plugin), published on 21 Sep 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-38073 in the wild and no public exploit code.

Affected packages and fixed versions:
- awesome-support/awesome-support (Packagist): affected all versions; fixed in 6.0.8
- awesome-support/awesome-support (Packagist): affected all versions; fixed in 6.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-38073/ (Markdown: https://insights.sbomify.com/CVE-2022-38073/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-38073
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-38073
- OSV: https://osv.dev/vulnerability/CVE-2022-38073

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-38073/
Summaries are generated and may contain mistakes; the official description above is the record.
